Notifications
Clear all

wpForo 1.x.x [Solved] Remove "Search Entire Post" Search Type and replace with search tags

7 Posts
5 Users
3 Likes
526 Views
eggsplain
Posts: 16
Topic starter
(@tumph)
Active Member
Joined: 2 years ago

Hello!

So far, my experience with wpforo has been excellent! However, I am running into an issue with the search functionality. For my website, I want people to be able to search for specific topics on the forum. And there are many possible "search types" you can use to do this.

 

For example, the default search type is set to "Search entire posts." Whenever you search with wpforo, the wpfs value gets set to the search term and the wpfin value gets by default set to "search entire posts." I have combed over my source code trying to find where this value gets set to search entire posts by default.

I was wondering if it was possible to set this value to "Find topics by tags" or even "Search titles only." Anything except "Search entire posts." 

Essentially with "Search entire posts" search type I am getting this error:

Warning:  mysqli_query(): (22003/1690): DOUBLE value is out of range in '((match `dbqkuecw9ded5r`.`p`.`title` against ('+fission*' in boolean mode)) + (match `dbqkuecw9ded5r`.`p`.`body` against ('+fission*' in boolean mode)))'

where "fission" is the example search query i used.

 

Since search entire posts type was giving me an error, I was thinking I could switch the default search type to something else, like the find topics by tags. But if the issue with "Search entire posts" is resolved, there is no need for me to switch to tags or title.

6 Replies
Robert
Posts: 9698
Admin
(@robert)
Support Team
Joined: 6 years ago

Hi @tumph,

Thank you for letting us know. We've already noticed about all issues and trying to fix it as soon as possible. The search function will be totally redeveloped in the near future releases.

NutritionChat
Posts: 22
(@nutritionchat)
Eminent Member
Joined: 2 years ago

Now that I've finally got some content on my new site, I can see how great the forum search actually is !

But I agree that it would be useful to be able to set the default search to titles only, to find the most relevant posts.

Keep up the good work, guys. 🙂 

 

eggsplain
Posts: 16
Topic starter
(@tumph)
Active Member
Joined: 2 years ago

Hey!

I solved the problem myself. I found that there was an error happening with the encoding of the sql tables within wpforo. The issue resided with the wpforo_topics and wpforo_posts. Somehow they got overwritten to being encoded into utf-8. However, I changed it to utf8-general-ci and everything is working again. 

Thanks so much for making wpforo, it has saved me a lot of time!

paulchoe
Posts: 13
(@paulchoe)
Active Member
Joined: 2 years ago

I am having the same issue.  I changed my database settings with the following command but I still get the error in search:

ALTER DATABASE database_name CHARACTER SET utf8 COLLATE utf8_general_ci;

Can you suggest any solution?

2 Replies
Alvina
Moderator
(@alvina)
Joined: 3 years ago

Member
Posts: 1872

Hi @paulchoe,

Please let us know have you use the last version(v. 1.9.1) of the wpForo plugin. If not please update the plugin to the latest version and check again.

paulchoe
(@paulchoe)
Joined: 2 years ago

Active Member
Posts: 13

Hi @alvina,

Yes, I am using v1.9.1 wpForo, which is the latest version at the present moment.

The problem is fixed after deleting the topic that contains the search word causing the error. I believe importing the database from another site caused the some conflict in mySQL database search.  After all, I would recommend the database collate option to be changed to utf8_general_ci, as others mentioned before. It is now working without any more error.  I am very happy with wpForo with its wonderful features so far. Thank you for your help.

Share: