Notifications
Clear all

[Closed] Question about an other plugin compatibility

26 Posts
4 Users
8 Reactions
14 K Views
Posts: 1602
Topic starter
(@anonymous20)
Noble Member
Joined: 8 years ago
Posted by: antonM

 

Sorry Anonymous20, it's needed to have a test system for experiments, which I don't have right now. Maybe a little bit later I will install a test system and will play with this plugin.

   

No problem. I have a lot of work to do before i need that. When time comes i will try to address it, maybe i will ask the other plugin developer, since he also is very kind.

cheers

antonM
Posts: 131
(@antonm)
Estimable Member
Joined: 8 years ago

Hi Anonymous20! Try this one:

in file wpf-hooks.php add to the end of file:

add_filter('wpforo_content_filter', 'wpaal_add_affiliate_links', 15);

in file post.php of your layout find:

echo wpforo_content_filter( wpforo_kses($post['body'], 'post') )

change it to:

echo apply_filters('wpaal_add_affiliate_links', wpforo_content_filter( wpforo_kses($post['body'], 'post') ));

Let me know if it will work.

antonM
Posts: 131
(@antonm)
Estimable Member
Joined: 8 years ago

Also it is needed to enable in settings of AAF

Active post types: Pages (check it)

 

Posts: 1602
Topic starter
(@anonymous20)
Noble Member
Joined: 8 years ago
Posted by: antonM

 

Also it is needed to enable in settings of AAF

Active post types: Pages (check it)

   

Can't enable permanently Pages, since i don't want that. But i will for a test session.

I will test your latest suggestion today or tomorrow and update here.

Thanks !

antonM
Posts: 131
(@antonm)
Estimable Member
Joined: 8 years ago

Sorry, I don't know another solution. If you use wpForo as shortcode on some page this setting of AAF is required. Another way is to contact with AAF plugin author.

Page 2 / 4