Notifications
Clear all

Does anyone have a good load time using wpforo?

6 Posts
3 Users
2 Likes
507 Views
Macky
Posts: 993
Topic starter
(@percysgrowroom)
Noble Member
Joined: 4 years ago

You all may have seen my post over the last month trying to speed up my forum. And though the community and admin have been very helpful, things are still not running at an acceptable speed. 

Now this wasn't the case for the front end of my site, before I started messing with things to try and improve forum speed the front end of my site was very fast, but the forum pages take at least 8 seconds to load. 

I have removed all plug in, and changed theme, and the site was still running slow on the forum end. I was hoping things would improve with the recent update but it hasnt. I notice no change in speed at all. So have reverted back to the theme i was using initially. 

I think the problem here could be down to the amount of Wpforo plug in i use ( I have all paid add on on my site) 

Now, I need these for my forum to be worth using, the ability to message people, upload pictures use adds, are all important features in my forum 

It seems as if the only way to get the page speed that this site ( wpforo.com) has, is to remove all of those plug ins?

Im not sure what to do now. I have really tried everything to improve page speed, and nothing seems to bring it to an acceptable standard. I cant remove plug ins that give my forum the functions it has, so have to deal with the slow page speed if im going to keep them? 

Im on a good hosting package too, A2 hosting prestige plus. For me to upgrade, it is going to cot me over £1000 a year on top of what i already pay. 

Im at a loss, and feel as if the only way for me to get a forum that people do not find slow, but has all the functions i need, is to find new software. 

My members and I all like the wpforo software, it is great stuff, but it is just too slow if you want to use all of the features with the add ons.

My licences ends in February i think. I will persevere and keep trying to improve the page speed, but TBF, I feel as if i have tried everything, and any more time spent doing this is going to be wasted. The only thing i can do differently is remove Wpforro plug ins that i need. 

I hope someone cna shed some light on this, is the page speed down to the amount of wpforo plugins i use? Its the only thing left that I can think of? 

If this is the case, then what plug ins do you recommend i remove?

Sorry for the long message but it all needs to be explained properly. Im a sure others have trouble with page speed too. 

This seems to be an issue that a few people are having, not just me. Again wpforo, is great software, but to have all the features to make others want to use it, you sacrfrice page speed. This needs to change IMO

There should be one plug on, coded together as a full wpforo add on? Maybe this will reduce the load? I have 7-8 wpforo plug ins, this surely can be reduced? 

Any way I have gone on for long enough, hope some one can shed some light on this issue. Please let me know if you have any ideas, or if you are having the same issues 🙂

 

 

 

5 Replies
adisaputro
Posts: 98
(@adisaputro)
Estimable Member
Joined: 4 years ago

Hi @percysgrowroom,

Moved to another forum software is not recommended because you will lost all of the customizations and very difficult to syncronize the database and maybe you will lost attachment, comments, etc.

If you still want to moved, maybe you can do it but not out of wordpress, example you can move to bbpress. BBpress is very light, but the features is very limited and very basic.

My WpForo website can load fast, 2-3 seconds on very basic Shared Hosting package...the key is not activating feature that you not used because every feature will make server request. Make sure you only using light theme like generatepress.

Reply
1 Reply
Macky
(@percysgrowroom)
Joined: 4 years ago

Noble Member
Posts: 993

@adisaputro I dont want to move mate, I like wpforo, and so do my users. I just have to figure out why the page speed is so slow. I tried generate press, there was very little difference in forum load time 

No my likes are not working properly either, you can only like one post at a time like the admin ajax isnt queuing, do you have this issue too, or is it just me? Please let me know, as I have to find and kill this problem if its just on my end lol 

Reply
Macky
Posts: 993
Topic starter
(@percysgrowroom)
Noble Member
Joined: 4 years ago

Still a few things to try before I look into moving to a new platform. I really dont want to move to another forum, but I dont want a slow forum either. 

Reply
1 Reply
adisaputro
(@adisaputro)
Joined: 4 years ago

Estimable Member
Posts: 98

@percysgrowroom,

The new version of WpForo is faster if you using php 8.0 and WP 5.6. You can try it.

Reply
Mallard14
Posts: 1
(@mallard14)
New Member
Joined: 2 years ago

We have been using this for several weeks now and it seems to be going nicely.

Reply