Notifications
Clear all

wpForo 1.x.x [Solved] Many issues please help

3 Posts
2 Users
0 Likes
923 Views
thecoltster1
Posts: 2
Topic starter
(@thecoltster1)
New Member
Joined: 3 years ago

Hello,

I had to update a bunch of plugins and it butchered my site.

I'm in the process of rebuilding. The site is travelingskateboarder.com.

Right now there is no way for people who aren't logged in to see the forum it just says "[wpforo]"; therefore they can't login. On top of that, seemingly out of nowhere prior to the updates the login screen dissapeared; which is the reason i tried to do the updates.

How do I let people who aren't logged in see the forums??? If all they see is the text [wpforo] they can't acssess the login dropdown menue. The settings are set to read all view all in the guest users. 

Everything seems correct to me. But nothing is working.

 

Edit: now it seems that guests can see the forum on pc but not mobile ???

2 Replies
thecoltster1
Posts: 2
Topic starter
(@thecoltster1)
New Member
Joined: 3 years ago

I almost have it fixed but now the login screen goes to my WP admin login screen?

Please help

Reply
CrisW
Posts: 281
(@crisw)
Reputable Member
Joined: 4 years ago
Posted by: thecoltster1

Hello,

I had to update a bunch of plugins and it butchered my site.

I'm in the process of rebuilding. The site is travelingskateboarder.com.

(1) Right now there is no way for people who aren't logged in to see the forum it just says "[wpforo]"; therefore they can't login. On top of that, seemingly out of nowhere prior to the updates the login screen dissapeared; which is the reason i tried to do the updates.

How do I let people who aren't logged in see the forums??? (2) If all they see is the text [wpforo] they can't acssess the login dropdown menue. The settings are set to read all view all in the guest users. 

Everything seems correct to me. But nothing is working.

 

Edit: now it seems that guests (3) can see the forum on pc but not mobile ???

And

(4) I almost have it fixed but now the login screen goes to my WP admin login screen?

Please help

Hi @thecoltster1 . Sometimes, when we change WP themes, the Menus get affected.  Also conflicting plugins do that.  

Items (1) and (2) shows up like that with just the shortcode "[wpforo]" on the wpforo forum page because the forum plugin is deactivated. 

You can activate / deactivate plugins by going to 

WP Dashboard > Plugins > Activate or Deactivate. 

On Item (3), I just checked on my iphone, I see you're using the StoreFront Theme, which is also a mobile theme, I can see your forum. (but only 2 forum menus - I'll try to help with that below)  🙂 

On Item (4), try and do this:  

1) Go to "Forum Dashboard"
2) Then select "Settings"
3) Select the "Features" tab.
4) You will see "Show Admin Bar for Members" (This option doesn't affect website admins.)
5) Select "NO"
6) Scroll at the very bottom and click "Update Options"
7) On the Front End of your forum, refresh page or click Control F5.

Since you are using Storefront theme (with WooCommerce plugin), there's a "Shop Login" (WooCommerce automatically puts these with your Top or Main Menu) and a "Forum Login" (which is a separate wpForo Navigation Menu).  But I see your wpForo Menu only has two menus:

  1. Recent Posts
  2. Members

I suggest, To add the the wpForo Menu links back, try and do the following:  

1) Log in as Admin
2) Go to WP Dashboard
3) Select "Appearance"
4) Select "Menus"
5) On the "Select a menu to edit" dropdown, select "wpForo Navigation (wpForo Menu)", then click the "Select" button
6) On the Menu Structure area is where you will add the following Custom Links:
7) We will add the following menus:

7.1) Forums
7.2) Members
7.3) Recent Posts
7.4) My Profile
7.5) > Activity (sub item)
7.6) > Account (sub item)
7.7) > Subscriptions (sub item)
7.8) Register
7.9) Login
7.10) Logout

So here we go .... 

7.1) Forums

Add this code in the "URL":

/%wpforo-home%/

Add this to the "Navigation Label"

Forums

 

7.2) Members

Add this code in the "URL":

/%wpforo-members%/

Add this to the "Navigation Label"

Members

7.3) Recent Posts

Add this code in the "URL":

/%wpforo-recent%/

Add this to the "Navigation Label"

Recent Posts

 

7.4) My Profile

Add this code in the "URL":

/%wpforo-profile-home%/

Add this to the "Navigation Label"

My Profile

 

7.5) > Activity (sub item)

Add this code in the "URL":

/%wpforo-profile-activity%/

Add this to the "Navigation Label"

Activity

7.6) > Account (sub item)

Add this code in the "URL":

/%wpforo-profile-account%/

Add this to the "Navigation Label"

Account

7.7) > Subscriptions (sub item)

Add this code in the "URL":

/%wpforo-profile-subscriptions%/

Add this to the "Navigation Label"

Subscriptions

 

7.8) Register

Add this code in the "URL":

/%wpforo-register%/

Add this to the "Navigation Label"

Register

 

7.9) Login

Add this code in the "URL":

/%wpforo-login%/

Add this to the "Navigation Label"

Login

 

7.10) Logout

Add this code in the "URL":

/%wpforo-logout%/

Add this to the "Navigation Label"

Logout

7.11) Then under the Menu Settings, under "Display Location", make sure you check the box "wpForo Menu"

7.12) Most importantly, click the SAVE MENU button. 🙂

Hope this helps reconstruct your wpForo Menu. The word "please" goes a long way.  🙂 Good luck and God bless you! 🙂

 

Reply
Share: