Notifications
Clear all

wpForo 1.x.x Display issue with widget

6 Posts
4 Users
0 Likes
2,496 Views
thomas1985
Posts: 8
Topic starter
(@thomas1985)
Active Member
Joined: 7 years ago

Hi,

First off, fantastic plug-in ! I can't tell how happy I am since I found it !

Big issue though : avatarsΒ won't display correctly in the widget.

Any idea how to fix this ?

Many thanks !

5 Replies
Sybar
Posts: 18
(@sybar)
Eminent Member
Joined: 7 years ago

Same problem here. If you go into user's Forum Profile --> Account tab and change

Wordpress avatar system to any other of the two versions it will display OK.

Looks like when wpForo grabs an avatar info from WordPress the display properties gets messed up. If you upload an avatar directly from wpForo it will show OK.

Obviously there's no way right now to force all players to do that. If it would be possible to chose to disable that 'Wordpress avatar system' from users' profile and make everyone add avatar again that would be temporary a solution.

Of course if wpForo would solve that display issue it would be even better.

Β 

Reply
Robert
Posts: 10286
Admin
(@robert)
Support Team
Joined: 8 years ago

wpForo works well with WordPress avatars (gravatar), but not with WordPress avatar plugins.

wpForo widget style works well on wpForo pages. If you use wpForo widget on non-forum pages you may have style issues like this one. Please leave some URL and I'll provide a simple CSS code to fix this theme conflict.

Reply
Sybar
Posts: 18
(@sybar)
Eminent Member
Joined: 7 years ago

Below is just an example of when avatart is grabbed from WordPress.

http://prnt.sc/c8j9d4

After I upload manually into wpForo everything is fine. As seen below.

http://prnt.sc/c8j94q

Like you said, it must be an theme issue. I'm not using any avatar plugins.

"Please leave some URL" ; sorry, what do you mean by that?

Thank you for the great support you provide πŸ™‚

Reply
thomas1985
Posts: 8
Topic starter
(@thomas1985)
Active Member
Joined: 7 years ago

Thanks Robert. Can't really display url here since it's a business related website. Anyway, I found an alternative solution. Keep up the good work it's perfect !

Reply
Page 1 / 2