Notifications
Clear all

[Solved] How to deal with hidden text?

4 Posts
2 Users
1 Likes
569 Views
Moderworks
Posts: 19
Topic starter
(@moderworks)
Eminent Member
Joined: 3 years ago

When you add a message through the editor TinyMCE unscrupulous users have the opportunity to add a hidden text, which is difficult to see the moderator. How to deal with it?

Example:

<p><span style="color: #ffffff;">Hidden spam text. Hidden spam text. Hidden spam text.</span></p>

Example:

Hidden spam text. Hidden spam text. Hidden spam text.

Under the background color

One more question.

3 Replies
Moderworks
Posts: 19
Topic starter
(@moderworks)
Eminent Member
Joined: 3 years ago

Perhaps the control panel provides the ability to disable some of the features of the visual editor for certain groups of users. But I could not find it.

Worth removing buttons forecolor, wpf_spoil,source_code (leave only for administrator, moderator)

You need to disable the plugin / wpforo/wpf-assets/js/tinymce-code.js for everyone except the administrator and moderator.

Through the functions.php file, I tried to disable the plugin and buttons. But these are half measures.

function editarbotoes_wpforoeditor( $buttons ) {
$buttons['tinymce']['toolbar1'] = '....';
$buttons['tinymce']['plugins'] = '....';
return $buttons;
}
add_filter( 'wpforo_editor_settings', 'editarbotoes_wpforoeditor');

This plugin will not disable

/wpforo/wpf-assets/js/tinymce-code.js

So how connected is here

/wpforo/wpf-assets/js/frontend.js

plugins: "hr,lists,textcolor,paste,wpautoresize,fullscreen,wpforo_pre_button,wpforo_link_button,wpforo_spoiler_button,wpforo_source_code_button,emoticons"

Dear support team, I hope that you can help me resolve this issue.

Sofy
Posts: 4057
 Sofy
Admin
(@sofy)
Support Team
Joined: 5 years ago

Hi @moderworks

When you add a message through the editor TinyMCE unscrupulous users have the opportunity to add a hidden text, which is difficult to see the moderator. How to deal with it?

Please add the following CSS code in Dashboard > Forums > Settings > Styles > "Custom CSS code" textarea, save it, delete all caches and press CRTL+F5 fronted. The issue should be solved

#wpforo #wpforo-wrap .wpfl-4 .wpf-content .wpforo-post-content * {
color: #000  !important;
}

Change the red marked code before using. 

The solution you've mentioned in this post doesn't work. Currently, there is no way to disable some of the features of the visual editor for certain usergroup yet. The custom code you've mentioned will be possible to use after the wpForo next version release (no ETA). Please wait for the next update. 

 

Moderworks
Posts: 19
Topic starter
(@moderworks)
Eminent Member
Joined: 3 years ago

Thank you!

Share: