Notifications
Clear all

wpForo 1.x.x [Closed] 500 error on my forum

6 Posts
3 Users
0 Reactions
8,779 Views
Posts: 5
Topic starter
(@shareforum)
Active Member
Joined: 6 years ago

Hi , i have this 500 error on my wpforo almost everyday at the same time , and i need service provider to clar the caches for me before the site will recover . I check the error log everytime this error appear and its an error on my wpforo , I will attach the error msge here hope you guys can help me with this, Thank you in advance!

Error as below:

  • [19-Dec-2018 09:35:29 UTC] WordPress database error Out of resources when opening file '/var/mysqltmp/#sql_bfc8b_5.MYI' (Errcode: 24 - Too many open files) for query SELECT * FROM `wp_wpforo_ads` WHERE `start_date` <= '2018-12-19 09:35:28' AND (`end_date` = '0000-00-00 00:00:00' OR `end_date` >= '2018-12-19 09:35:28') AND `forumids` REGEXP '(,|^)(0)(,|$)' AND `tpllocs` REGEXP '(,|^)(top)(,|$)' AND `status` = 1 ORDER BY RAND() LIMIT 1 made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/plugins/wpforo/wpf-themes/classic/index.php'), include('/plugins/wpforo/wpf-themes/classic/header.php'), do_action('wpforo_top_hook'), WP_Hook->do_action, WP_Hook->apply_filters, wpforo_do_top_ads, wpForoAD->get_ads
  • [19-Dec-2018 09:35:29 UTC] PHP Warning: mysqli_query(): (HY000/23): Out of resources when opening file '/var/mysqltmp/#sql_bfc8b_5.MYI' (Errcode: 24 - Too many open files) in /home2/sexbombed/shareforum.online/wp-includes/wp-db.php on line 1924
  • [19-Dec-2018 09:35:28 UTC] WordPress database error Can't open file: './sexbombe_wrdp3/wp_term_taxonomy.frm' (errno: 24 - Too many open files) for query SELECT tr.object_id FROM wp_term_relationships AS tr INNER JOIN wp_term_taxonomy AS tt ON tr.term_taxonomy_id = tt.term_taxonomy_id WHERE tt.taxonomy IN ('nav_menu') AND tt.term_id IN ('44') ORDER BY tr.object_id ASC made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/plugins/wpforo/wpf-themes/classic/index.php'), get_header, locate_template, load_template, require_once('/themes/govideo/header.php'), get_template_part, locate_template, load_template, require('/themes/govideo/template-parts/navigation/navigation-top.php'), wp_nav_menu, wp_get_nav_menu_items, get_objects_in_term
  • [19-Dec-2018 09:35:26 UTC] WordPress database error Out of resources when opening file './sexbombe_wrdp3/wp_options.MYD' (Errcode: 24 - Too many open files) for query SELECT option_value FROM wp_options WHERE option_name = 'can_compress_scripts' LIMIT 1 made by require('wp-blog-header.php'), require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, WP_Hook->apply_filters, wp_widgets_init, do_action('widgets_init'), WP_Hook->do_action, WP_Hook->apply_filters, WP_Widget_Factory->_register_widgets, WP_Widget->_register, WP_Widget_Text->_register_one, wp_add_inline_script, wp_scripts, WP_Scripts->__construct, WP_Scripts->init, do_action_ref_array, WP_Hook->do_action, WP_Hook->apply_filters, wp_default_packages, wp_register_tinymce_scripts, script_concat_settings, get_site_option, get_network_option, get_option
  • [19-Dec-2018 09:35:23 UTC] WordPress database error Can't open file: './sexbombe_wrdp3/wp_terms.frm' (errno: 24 - Too many open files) for query SELECT t.*, tt.* FROM wp_terms AS t INNER JOIN wp_term_taxonomy AS tt ON t.term_id = tt.term_id WHERE tt.taxonomy IN ('category') ORDER BY t.name ASC made by require('wp-blog-header.php'), require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), include('/themes/govideo/functions.php'), require_once('/themes/govideo/inc/customizer-options.php'), govideo_customizer_library_options, get_categories, get_terms, WP_Term_Query->query, WP_Term_Query->get_terms
  • [19-Dec-2018 09:35:23 UTC] WordPress database error Out of resources when opening file './sexbombe_wrdp3/wp_term_relationships.MYD' (Errcode: 24 - Too many open files) for query SELECT tr.object_id FROM wp_term_relationships AS tr INNER JOIN wp_term_taxonomy AS tt ON tr.term_taxonomy_id = tt.term_taxonomy_id WHERE tt.taxonomy IN ('nav_menu') AND tt.term_id IN ('65') ORDER BY tr.object_id ASC made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/plugins/wpforo/wpf-themes/classic/index.php'), include('/plugins/wpforo/wpf-themes/classic/header.php'), wpForoTemplate->nav_menu, wp_nav_menu, wp_get_nav_menu_items, get_objects_in_term
  • [17-Dec-2018 10:12:43 UTC] WordPress database error Out of resources when opening file './sexbombe_wrdp3/wp_postmeta.MYD' (Errcode: 24 - Too many open files) for query SELECT post_id, meta_key, meta_value FROM wp_postmeta WHERE post_id IN (1915) ORDER BY meta_id ASC made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/plugins/wpforo/wpf-themes/classic/index.php'), dynamic_sidebar, WP_Widget->display_callback, WP_Widget_Media->widget, WP_Widget_Media_Image->render_media, WP_Widget_Media->is_attachment_with_mime_type, wp_attachment_is, get_attached_file, get_post_meta, get_metadata, update_meta_cache
  • [17-Dec-2018 10:12:42 UTC] WordPress database error Can't open file: './sexbombe_wrdp3/wp_postmeta.frm' (errno: 24 - Too many open files) for query SELECT post_id, meta_key, meta_value FROM wp_postmeta WHERE post_id IN (2026) ORDER BY meta_id ASC made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/plugins/wpforo/wpf-themes/classic/index.php'), dynamic_sidebar, WP_Widget->display_callback, WP_Widget_Media->widget, WP_Widget_Media_Image->render_media, WP_Widget_Media->is_attachment_with_mime_type, wp_attachment_is, get_attached_file, get_post_meta, get_metadata, update_meta_cache
  • [17-Dec-2018 10:12:41 UTC] WordPress database error Out of resources when opening file './sexbombe_wrdp3/wp_postmeta.MYD' (Errcode: 24 - Too many open files) for query SELECT post_id, meta_key, meta_value FROM wp_postmeta WHERE post_id IN (2035) ORDER BY meta_id ASC made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/plugins/wpforo/wpf-themes/classic/index.php'), dynamic_sidebar, WP_Widget->display_callback, WP_Widget_Media->widget, WP_Widget_Media_Image->render_media, WP_Widget_Media->is_attachment_with_mime_type, wp_attachment_is, get_attached_file, get_post_meta, get_metadata, update_meta_cache
  • [17-Dec-2018 10:12:36 UTC] WordPress database error Can't open file: './sexbombe_wrdp3/wp_wpforo_forums.frm' (errno: 24 - Too many open files) for query SELECT count(*) FROM `wp_wpforo_forums` WHERE `parentid` = 49 AND `is_cat` = 0 made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/plugins/wpforo/wpf-themes/classic/index.php'), include('/plugins/wpforo/wpf-themes/classic/layouts/1/forum.php'), wpForoForum->get_forums
  • [17-Dec-2018 10:12:35 UTC] WordPress database error Out of resources when opening file '/var/mysqltmp/#sql_bfc8b_4.MYD' (Errcode: 24 - Too many open files) for query SELECT * FROM `wp_wpforo_ads` WHERE `start_date` <= '2018-12-17 10:12:34' AND (`end_date` = '0000-00-00 00:00:00' OR `end_date` >= '2018-12-17 10:12:34') AND `forumids` REGEXP '(,|^)(0)(,|$)' AND `tpllocs` REGEXP '(,|^)(forum_loop)(,|$)' AND `status` = 1 ORDER BY RAND() made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/plugins/wpforo/wpf-themes/classic/index.php'), include('/plugins/wpforo/wpf-themes/classic/layouts/1/forum.php'), do_action('wpforo_loop_hook'), WP_Hook->do_action, WP_Hook->apply_filters, wpforo_do_loop_ads, wpForoAD->get_ads
  • [17-Dec-2018 10:12:35 UTC] PHP Warning: mysqli_query(): (HY000/23): Out of resources when opening file '/var/mysqltmp/#sql_bfc8b_4.MYD' (Errcode: 24 - Too many open files) in /home2/sexbombed/shareforum.online/wp-includes/wp-db.php on line 1924
5 Replies
Robert
Posts: 10529
Admin
(@robert)
Support Team
Joined: 8 years ago

This has not direct relation to wpForo. Errors are from all part of your website. It seems your website hosting service resources are not enough for your traffic or your website is under attack. I'd recommend temporary disable wpForo Ads Manager addon, because I see some errors from that addon. If you still see such errors then you should contact to your hosting service, they are not wpForo errors.

2 Replies
(@shareforum)
Joined: 6 years ago

Active Member
Posts: 5
Posted by: Robert

This has not direct relation to wpForo. Errors are from all part of your website. It seems your website hosting service resources are not enough for your traffic or your website is under attack. I'd recommend temporary disable wpForo Ads Manager addon, because I see some errors from that addon. If you still see such errors then you should contact to your hosting service, they are not wpForo errors.

Hi thanks i will try contacting my host but if the error on ddon wpforo adver , can it be solve?

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10529
Posted by: shareforum
Posted by: Robert

This has not direct relation to wpForo. Errors are from all part of your website. It seems your website hosting service resources are not enough for your traffic or your website is under attack. I'd recommend temporary disable wpForo Ads Manager addon, because I see some errors from that addon. If you still see such errors then you should contact to your hosting service, they are not wpForo errors.

Hi thanks i will try contacting my host but if the error on ddon wpforo adver , can it be solve?

The Ads manager error only comes when your database is down, this error is a result not a reason.

Posts: 1602
(@anonymous20)
Noble Member
Joined: 8 years ago

Start from removing the caching plugin you use. If you continue to use it (or any caching), exclude wpforo pages from it:

<!-- WP Fastest Cache file was created in 1.2810969352722 seconds, 
on 19-12-18 16:39:28 -->

Also this seems like a very poor hosting plan, you definitely need to contact your hosting provider.

1 Reply
(@shareforum)
Joined: 6 years ago

Active Member
Posts: 5
Posted by: Anonymous20

Start from removing the caching plugin you use. If you continue to use it (or any caching), exclude wpforo pages from it:

<!-- WP Fastest Cache file was created in 1.2810969352722 seconds, 
on 19-12-18 16:39:28 -->

Also this seems like a very poor hosting plan, you definitely need to contact your hosting provider.

Hi thks for the advise , i will excluded wpforo page from caching and see how it goes too!