Notifications
Clear all

wpForo 1.x.x [Solved] all buttons don't work when i am not logged in

6 Posts
2 Users
0 Likes
860 Views
Posts: 19
Topic starter
(@kimia)
Eminent Member
Joined: 5 years ago

when i am not logged in , if i click on **add topic**  button or any other buttons,they  don't work!!!!!

this is  so strange because at least it doesn't show me any error or warning...

i don't know what is wrong with forum

also when i am logged in as forum member , links which i circled in picture below are disabled and don't work!!!!

please help me!!!!!

5 Replies
Posts: 19
Topic starter
(@kimia)
Eminent Member
Joined: 5 years ago

i checked my console.log. and it says   "load.visible is not a function"  ,how can i solve this issue??

4 Replies
Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4310

@kimia

This kind of issue is usually caused by either conflict with other plugins or the active theme. 

Please deactivate the plugins one by one and check after each deactivation to find the problem maker one.

Don't forget to press Ctrl+F5(twice) on frontend each time before checking.

(@kimia)
Joined: 5 years ago

Eminent Member
Posts: 19

@sofy

i write a hook in my functions.php file, and move scripts to be loaded in footer, and problem solved.

 

Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4310

Thank you for letting us know.

Glad to hear that the issue is solved. 

(@kimia)
Joined: 5 years ago

Eminent Member
Posts: 19

@sofy

you're welcome 🙂