Notifications
Clear all

wpForo 1.x.x [Closed] All posts and commnets are held in moderation

12 Posts
3 Users
0 Reactions
1,825 Views
Posts: 16
Topic starter
(@synergy)
Eminent Member
Joined: 4 years ago

Hi Admin,

  1. All posts by users are being held up for me to moderate. this even applies to users who have over 10 post. I have the settings as seen in the screenshot attached
  2. How do I disable normal video uploads and allow only video embedding from 3rd party like YouTube
11 Replies
Sofy
Posts: 4421
 Sofy
Admin
(@sofy)
Support Team
Joined: 6 years ago

Hi @synergy,

All posts by users are being held up for me to moderate. this even applies to users who have over 10 post. I have the settings as seen in the screenshot attached

Navigate to Dashboard > Forums > Usergroups admin page. Edit all Usergroups one by one and make sure the “Can pass moderation” permission is enabled:

More info here: https://gvectors.com/how-to-disable-topics-and-posts-moderation/

How do I disable normal video uploads and allow only video embedding from 3rd party like YouTube

Please follow this support topic: https://wpforo.com/community/general-discussions/how-to-insert-youtube-link/#post-17069

Posts: 16
Topic starter
(@synergy)
Eminent Member
Joined: 4 years ago

Thanks for that.

I discovered that a newly created topics and comments are sometimes hidden for guests. such that if i view my forum as a guest i will not see them but once logged in as any user it comes up. If i logout it disappears again.

I have cleared all caches and cleared caches of browser.

What could be causing it and what is the fix?

I want all topics and comments to be available for all usergroup including guests as soon as they are created

6 Replies
Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4421

@synergy,

I guess the topics are either private or they belong to the forums that are not accessible for the Guest usergroup. 

 

(@synergy)
Joined: 4 years ago

Eminent Member
Posts: 16

@sofy I have carefully checked and none of the above is the cause. In fact except admin and moderator no user is permited to set topic private.

See my settings in the screenshots

 

(@synergy)
Joined: 4 years ago

Eminent Member
Posts: 16
Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4421

@synergy,

Please send the admin login details to info[at]gvectors.com email address and include the topic URL with the issue in the email content to allow us to check and find the reason for this issue. 

 

(@synergy)
Joined: 4 years ago

Eminent Member
Posts: 16

@sofy I have sent the email to the address given. Thanks, I really appreciate you guys swift responses and amazing support

 

Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4421

@synergy,

The issue comes from the LiteSpeed Cache plugin. You should exclude wpForo pages from the plugin settings. 

I'm not familiar with the plugin settings, but found the following article, it may be helpful for you. 

https://buildwoofunnels.com/docs/aerocheckout/caching/litespeed-cache/

The rest of the issues you've faced may also come from the plugin please deactivate the plugin and check again. 

For removing Social Networks fields in profile Solution is here:

https://wpforo.com/community/how-to-and-troubleshooting-2/editing-profiles-social-media-fields-wp-discord-app/#post-18147

 

Posts: 16
Topic starter
(@synergy)
Eminent Member
Joined: 4 years ago

Wow! Am so happy, thanks. I deleted that plugin and everything fell into place!

Posts: 1602
(@anonymous20)
Noble Member
Joined: 8 years ago

There is no reason to delete the plugin, Litespeed cache is very powefull if you are on a Litespeed webserver.

It works fine, if you:

1. Exclude wpForo page from caching

2. Disable any caching for logged in users

3. Disable any optimizations for logged in users

4. Exclude any optimizations for wpForo page (still this can work for advanced users)

Page 1 / 2