Notifications
Clear all

wpForo 1.x.x [Solved] Cannot Login as Any User

15 Posts
4 Users
0 Likes
2,620 Views
Spectral
Posts: 7
Topic starter
(@spectra)
Active Member
Joined: 5 years ago

Hello,

We have a problem where when we try to sign in that it says on the top right that we have logged in and welcome, but it then keeps making us try to log in - it just keeps showing the username and password screen.

 

Any thoughts? Nobody can log in - only admins who are already logged into wordpress.

14 Replies
1 Reply
Spectral
(@spectra)
Joined: 5 years ago

Active Member
Posts: 7

Also, I have tried disabling all plugins I can see and still no luck.

Anonymous20
Posts: 1602
(@anonymous20)
Noble Member
Joined: 6 years ago

Do you mean that the problem happens only when wpForo is enabled ? Not sure i understand.

Also wpForo doesn't handle logins and registrations.

Robert
Posts: 9325
Admin
(@robert)
Support Team
Joined: 6 years ago
Posted by: spectreg4

Hello,

We have a problem where when we try to sign in that it says on the top right that we have logged in and welcome, but it then keeps making us try to log in - it just keeps showing the username and password screen.  

wpForo checks if you're logged before asking you to loggin, but this process doesn't have any relation to login process. I think your WordPress has session/coolie issue and can't keep users logged-in or it doesn't authorize it at all. Please deactivate all plugins (including wpForo) and check it again.

Spectral
Posts: 7
Topic starter
(@spectra)
Active Member
Joined: 5 years ago

If I go to the normal WordPress admin login for my page, then I am able to log in and edit WordPress as I see fit - even post on the forums. However, when someone comes to the page and tries to log in on the forums, it will say "welcome" in green as if they logged in, but kick them back without logging in and never allow them to actually log in - they can only keep typing in their email and password.

This is only happening, it would seem, with Wpforo as I can login at wp-login anytime I want easily.

Anonymous20
Posts: 1602
(@anonymous20)
Noble Member
Joined: 6 years ago

I would suggest to follow the standard WP debug procedure, enable debug.log, disable some plugins that have to do with login/registration maybe. Also it would usefull to post a url (if you can/want) so we can check.

Also do you use ANY caching plugin ?

 

Page 1 / 3
Share: