Notifications
Clear all

wpForo 1.x.x [Closed] Do not work iframe and icons etc

18 Posts
2 Users
0 Likes
97.7 K Views
Melafon
Posts: 47
Topic starter
(@rexxx)
Trusted Member
Joined: 6 years ago

Hello. After last update wpforo on forum russpuss do not working iframe, and icons on forum... Before all work right. Can’t understanding why... How I can fix it? For example attached screenshot. Thanks.

17 Replies
Robert
Posts: 10478
Admin
(@robert)
Support Team
Joined: 8 years ago

@rexxx,

New versions of wpForo comes with updated Font-Awesoe 5 icon lib. I see you've disabled wpForo Font-Awesome lib. You're using hard codded 4.7 version. I see this script in your theme header:

<link rel='stylesheet' id='bfa-font-awesome-css' href='//cdn.jsdelivr.net/fontawesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />

Please find and remove this from theme files or from other places (you know better). Then navigate to Dashboard > Forums > Settings > Features admin page, Find wpForo FontAwesome lib option and enable it.

wpForo Font Awesome lib is updated to version 5. If your theme doesn't have v5 and you've disabled wpForo Font Awesome lib, please enable it back in Settings > Features admin page. If you've changed forum icons, member fields and reputation icons, please edit and insert new values using Font Awesome 5 new classes.

This has been mentioned in version release summary. Please keep reading changelog and Update Notes before updating your forum: https://wpforo.com/community/wpforo-announcements/wpforo-1-4-6-is-released/

 

Robert
Posts: 10478
Admin
(@robert)
Support Team
Joined: 8 years ago

After last update wpforo on forum russpuss do not working iframe

Old wpForo versions was decoding HTML codes. Now you should put this code in Text mode of the editor. Please, edit the post, copy the iframe code, click on {;} button of editor toolbar, paste there, click save ad update it.

Melafon
Posts: 47
Topic starter
(@rexxx)
Trusted Member
Joined: 6 years ago
Posted by: Robert

@rexxx,

New versions of wpForo comes with updated Font-Awesoe 5 icon lib. I see you've disabled wpForo Font-Awesome lib. You're using hard codded 4.7 version. I see this script in your theme header:

<link rel='stylesheet' id='bfa-font-awesome-css' href='//cdn.jsdelivr.net/fontawesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />

Please find and remove this from theme files or from other places (you know better). Then navigate to Dashboard > Forums > Settings > Features admin page, Find wpForo FontAwesome lib option and enable it.

wpForo Font Awesome lib is updated to version 5. If your theme doesn't have v5 and you've disabled wpForo Font Awesome lib, please enable it back in Settings > Features admin page. If you've changed forum icons, member fields and reputation icons, please edit and insert new values using Font Awesome 5 new classes.

This has been mentioned in version release summary. Please keep reading changelog and Update Notes before updating your forum: https://wpforo.com/community/wpforo-announcements/wpforo-1-4-6-is-released/

 

Thanks. Now icons work right. 

Look screenshot pls.

Melafon
Posts: 47
Topic starter
(@rexxx)
Trusted Member
Joined: 6 years ago

Integrate pls wpforo for Apple. iPad, iPhone etc... to much different bugs on Apple.  😔 Thanks.

Page 1 / 4