Notifications
Clear all

wpForo 1.x.x [Solved] Emails are nor sent according to the user´s language

5 Posts
2 Users
1 Likes
539 Views
Posts: 3
Topic starter
(@yantal)
Active Member
Joined: 1 year ago

Hello, configure a forum with two languages ​​(ES and EN). On the site I use the WPML multilingual plugin.

For access, set up two pages: ES: Destinosagrado.com/foro EN: Destinosagrado.com/en/foro.

I find two errors.
ONE: The Topic, all mail messages are sent in Spanish despite the fact that the user's language is English and they are browsing a page declared in English Language.

TWO, At the beginning, it always refers me to the page in Spanish. How can I make it work perfectly?  Thanks !!!

(translated from Spanish by google)

wpForo Version
1.9.9.1
WordPress Version
5.9.2
8
10.3.32-MariaDB-cll-lve - MariaDB Server
Topic Tags
4 Replies
Chris
Posts: 3531
Admin
(@chris)
Support Team
Joined: 2 years ago

Hi @yantal,

If that plugin doesn't change user's language in Dashboard > Profile(User Profile), it won't change the email language as well.

Also, if you go to Dashboard > Forums > Settings > Emails Tab, there you can see all email which are used for wpForo and also there are several Email forums which have "Overwrite WordPress New User Registration Email for Admins:" option, if this option is enabled, the website language wont change the language for that current email.

Posted by: @yantal

TWO, At the beginning, it always refers me to the page in Spanish. How can I make it work perfectly?  Thanks !!!

You should ask, the plugin support team I am not familiar to WPML multilingual plugin.

Posts: 3
Topic starter
(@yantal)
Active Member
Joined: 1 year ago

Hello!!!

I am having 3 problems, I rewrite them according to everything sent.

The Language of the Site is Spanish and as a secondary language it is English and I use the WPML plugin

Errors

1. For users with languages ​​in English, the System sends them emails in Spanish (language of the site) regardless of whether the option to overwrite it is activated or not.

2. For Spanish users the access page is: /foro (Spanish language), For English users the page is: /en/foro (English language)

Everyone who logs in is redirected to the page in Spanish, that is: /foro

3. The error code appears in the response field: Failed to load plugin url: https://destinosagrado.com/wp-includes/js/tinymce/langs/es.js

TKS!!!!

2 Replies
Chris
Admin
(@chris)
Joined: 2 years ago

Support Team
Posts: 3531

@yantal

Posted by: @yantal

1. For users with languages ​​in English, the System sends them emails in Spanish (language of the site) regardless of whether the option to overwrite it is activated or not.

If the overwrite option is disabled, the email are sent by WordPress not wpForo.

Posted by: @yantal

2. For Spanish users the access page is: /foro (Spanish language), For English users the page is: /en/foro (English language)

I have set English on your homepage then opened the forum, the language has stayed English

(@yantal)
Joined: 1 year ago

Active Member
Posts: 3

@chris MUCHÍSIMAS GRACIAS!! Entendido y todo funcionando.