Notifications
Clear all

wpForo 1.x.x [Closed] I can't login to the admin panel because it goes through wp-foro. Something has broken!

21 Posts
3 Users
0 Reactions
2,858 Views
Posts: 73
 TGW
Topic starter
(@tgw)
Estimable Member
Joined: 7 years ago

@robert

They replied to me with this:

Seems the session path is all good:

/var/cpanel/php/sessions/ea-php56

As per the recommendation in the provided thread, I have updated the session.save_path to be the /tmp folder on the account, with the path '/home/thegre/tmp'. I checked the folder and I can see that the session files are being created, however, the warnings are still present on the login page and the logging in is not possible.

I cleared all caches of the website, but the issue continues.

Could you please, share that information with them and ask them if there are any checks/changes that need to be performed for the plugin so that the new path is detected.

At the moment, the website is configured to work with the latest 7.3.7 PHP version, while the wpforo is outdated.

Share this information with the developers too and ask them whether this version of the plugin can work with the newest PHP version and whether the update needs to be performed.

Let us know if there are any changes required from our end and we will gladly help.

Best Regards

Miroslav Rangelov
Technical Support Team

What do you think?

He said the wpforo is outdated - it may not be the latest release, but it's like a month old at most. Like I said, I haven't updated/edited/touched any website settings in over a month

@anonymous20

Thanks for letting me know. I'll get to fixing that as soon as this is fixed.

 

Posts: 1602
(@anonymous20)
Noble Member
Joined: 8 years ago

@tgw Can you see/check what is the FILE permission of wp-config.php ? Is it 644 or 600 ?

 

4 Replies
 TGW
(@tgw)
Joined: 7 years ago

Estimable Member
Posts: 73
Posted by: @anonymous20

@tgw Can you see/check what is the FILE permission of wp-config.php ? Is it 644 or 600 ?

 

@anonymous20

It's 600. Pic attached. I have no idea what 600 means, I'm in over my head when it comes to server stuff

Posted by: @anonymous20

Also, i found your error (not exactly but most of it) in Wordpress.org, in two different caching plugins forums.

I see you run Rocket cache ? Could your problems be related to Rocket cache ?

 

Should I delete the rocketcache folder and see if that fixes it? I can delete all caching plugings to see if it helps. I do have a website backup from this weekend just incase.

 I knew that an error code was popping up for a few months now, but it used to go away with a page refresh and only showed up very rarely. And the website ran fine. I don't know what happened today to cause it to become a major issue

(@anonymous20)
Joined: 8 years ago

Noble Member
Posts: 1602
Posted by: @tgw
Posted by: @anonymous20

@tgw Can you see/check what is the FILE permission of wp-config.php ? Is it 644 or 600 ?

 

It's 600. Pic attached

Should I delete the rocketcache folder and see if that fixes it? I can delete all caching plugings to see if it helps. I do have a website backup from this weekend just incase.

To  be honest I knew that an error code was popping up for a few months now, but it used to go away with a page refresh and the website ran fine. I don't know what happened suddenly today to cause it to become a major issue

Can you make the wp-config.php 644 and see if the error is gone ?

And try things ONE BY ONE. Not all at once. No need to delete Rocket cache, just disable it.

 TGW
(@tgw)
Joined: 7 years ago

Estimable Member
Posts: 73

@anonymous20

Changed to 644, error codes didn't change. It's the same 7 on the login, same 2 across the website

EDIT: NVM I figured out how to disable. Rename folder

(@anonymous20)
Joined: 8 years ago

Noble Member
Posts: 1602
Posted by: @tgw

@anonymous20

Changed to 644, error codes didn't change. It's the same 7 on the login, same 2 across the website

EDIT: NVM I figured out how to disable. Rename folder

It is the same error as here:

https://wpforo.com/community/how-to-and-troubleshooting-2/warning-message/

and also a LOT of same problem if you search the internet. Related either to hosting (tmp path) or a plugin.

Try to disable one by one your plugins. If everything is disabled (except wpForo) and you didn't find the cause, then i guess it is a hosting problem, or a Cpanel problem.

Posts: 1602
(@anonymous20)
Noble Member
Joined: 8 years ago

Also, i found your error (not exactly but most of it) in Wordpress.org, in two different caching plugins forums.

I see you run Rocket cache ? Could your problems be related to Rocket cache ?

Posts: 1602
(@anonymous20)
Noble Member
Joined: 8 years ago
Posted by: @tgw

@anonymous20

This is awkward, but could you send me that debug log if you still have it on file? Or let me know how to get it?

I'm trying to convince siteground that something happened on the server end and needs correction. And maybe the log will help them figure it out

https://the-great-work.org/wp-content/debug.log

log files, .ht*** files and other files should be automatically blocked (403) not by you but from the hosting setup. Unless you manage your server, then it is your fault.

As for your support guys whereever you host, they have no idea what they are talking about. Sorry, but that is the truth.

Saying for example that wpForo version is not compatible/updated and things like that.

Ask for your problem to be escalated to a proper support team.

Posts: 1602
(@anonymous20)
Noble Member
Joined: 8 years ago

Also something else, rather strange with your site. The wp-rocket cache signature

<!-- This website is like a Rocket, isn't it?

should appear at the very end of the page. And in your case it is not. There are some scripts AFTER the signature (meaning the end of the cached page). That is strange, unless wp-rocket works like that, mixing things (i doubt it).

 

Page 2 / 3