Notifications
Clear all

wpForo 1.x.x [Closed] I can't login to the admin panel because it goes through wp-foro. Something has broken!

21 Posts
3 Users
0 Reactions
2,859 Views
Posts: 73
 TGW
Topic starter
(@tgw)
Estimable Member
Joined: 7 years ago

This is the error that I am getting across the top of the whole website:

 

Warning: session_start(): open(/var/cpanel/php/sessions/ea-php56/sess_e846ae88923f14430d2eee26cc25bc68, O_RDWR) failed: No such file or directory (2) in /home/thegre/public_html/wp-content/plugins/wpforo/wpf-includes/class-notices.php on line 16

Warning: session_start(): Failed to read session data: files (path: /var/cpanel/php/sessions/ea-php56) in /home/thegre/public_html/wp-content/plugins/wpforo/wpf-includes/class-notices.php on line 16

And then when I go to the login page, put in my credentials, and try to login:

 

Warning: session_start(): open(/var/cpanel/php/sessions/ea-php56/sess_544a9fa45f3e64f3e5f534112a6ae06c, O_RDWR) failed: No such file or directory (2) in /home/thegre/public_html/wp-content/plugins/wpforo/wpf-includes/class-notices.php on line 16

Warning: session_start(): Failed to read session data: files (path: /var/cpanel/php/sessions/ea-php56) in /home/thegre/public_html/wp-content/plugins/wpforo/wpf-includes/class-notices.php on line 16

Warning: Cannot modify header information - headers already sent by (output started at /home/thegre/public_html/wp-content/plugins/wpforo/wpf-includes/class-notices.php:16) in /home/thegre/public_html/wp-includes/pluggable.php on line 928

Warning: Cannot modify header information - headers already sent by (output started at /home/thegre/public_html/wp-content/plugins/wpforo/wpf-includes/class-notices.php:16) in /home/thegre/public_html/wp-includes/pluggable.php on line 929

Warning: Cannot modify header information - headers already sent by (output started at /home/thegre/public_html/wp-content/plugins/wpforo/wpf-includes/class-notices.php:16) in /home/thegre/public_html/wp-includes/pluggable.php on line 930

Warning: Cannot modify header information - headers already sent by (output started at /home/thegre/public_html/wp-content/plugins/wpforo/wpf-includes/class-notices.php:16) in /home/thegre/public_html/wp-includes/pluggable.php on line 1251

Warning: Cannot modify header information - headers already sent by (output started at /home/thegre/public_html/wp-content/plugins/wpforo/wpf-includes/class-notices.php:16) in /home/thegre/public_html/wp-includes/pluggable.php on line 1254

 

You can check it out here:

https://the-great-work.org/community/main-forum/

 

So firstly, how can I get around the wp-foro sign in? Every time I try to got to /wp-admin/ or /admin/ I have to use the wpforo sign-in, which obviously isn't going to work right now. Is there a way to get around this?

 

And once that is done, how do I fix this?

 

I did not make any changes to the website. I haven't updated any plugins or themes in weeks, and I haven't updated the wordpress version either. It just broke suddenly today with these error messages

20 Replies
Robert
Posts: 10545
Admin
(@robert)
Support Team
Joined: 8 years ago

Hi @tgw,

First please let us know what have you done recently? You've damaged something, you've updated or installed something. You've made some changes in server or something else...

1 Reply
 TGW
(@tgw)
Joined: 7 years ago

Estimable Member
Posts: 73
Posted by: @robert

Hi @tgw,

First please let us know what have you done recently? You've damaged something, you've updated or installed something. You've made some changes in server or something else...

Hi @Robert

I'm at a loss because I haven't done anything to the website in weeks. I've got a wordpress update and like 10 plugin updates sitting in the notifications (when I checked yesterday), because I haven't updated or touched any settings.

I haven't updated wpforo either since the last version

I know things do not just break by themselves, but I haven't changed anything in weeks. And it was working fine yesterday.

Is there a way around the wp-foro login that could get me to the admin panel so I can check if something changed through an auto-update or something?

Robert
Posts: 10545
Admin
(@robert)
Support Team
Joined: 8 years ago

You've updated server PHP and the session folder is changed or the folder permission is not 755 / 777. So wpForo can't initiate PHP session. This is not wpForo Issue. This is a BIG problem of your server PHP and session directory. Please contact to your hosting support and ask them to fix PHP Session issue as soon as possible. There is no any issue from wpForo and there is no any solution from wpForo side.

Similar situation in web: https://forums.cpanel.net/threads/cpanel-whm-64-php-session-path-errors.596863/

3 Replies
 TGW
(@tgw)
Joined: 7 years ago

Estimable Member
Posts: 73
Posted by: @robert

You've updated server PHP and the session folder is changed or the folder permission is not 755 / 777. So wpForo can't initiate PHP session. This is not wpForo Issue. This is a BIG problem of your server PHP and session directory. Please contact to your hosting support and ask them to fix PHP Session issue as soon as possible. There is no any issue from wpForo and there is no any solution from wpForo side.

Similar situation in web: https://forums.cpanel.net/threads/cpanel-whm-64-php-session-path-errors.596863/

OK, it's siteground, I'll contact them

I've got cPanel access, is there anything I could do through there to fix the folder permission (if that's the issue?)

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10545

@tgw

I'm sorry but I can't guide you here. It's better to let the hosting support to do that. The PHP and session folders are defined in PHP settings so they can find and fix the issue. The permission can be correct, but the directory path is incorrect in updated PHP configuration.

 TGW
(@tgw)
Joined: 7 years ago

Estimable Member
Posts: 73
Posted by: @robert

You've updated server PHP and the session folder is changed or the folder permission is not 755 / 777. So wpForo can't initiate PHP session. This is not wpForo Issue. This is a BIG problem of your server PHP and session directory. Please contact to your hosting support and ask them to fix PHP Session issue as soon as possible. There is no any issue from wpForo and there is no any solution from wpForo side.

Similar situation in web: https://forums.cpanel.net/threads/cpanel-whm-64-php-session-path-errors.596863/

I just checked folder permissions, they are 755

@robert did the response from siteground support tell you anything?

@Anonymous20

I've knocked out pretty much every other plugin (that was active) one by one and the issues hasn't gone away

Posts: 1602
(@anonymous20)
Noble Member
Joined: 8 years ago

@tgw I was able to download your huge debug.log of your site and that is something it SHOUDN'T happen. It should return a 403 on a properly set web server/plan.

It seems your security is very weak. Find someone to fix them for your or ask your hosting company to fix them.

 

Posts: 1602
(@anonymous20)
Noble Member
Joined: 8 years ago

And your problems started not as you say recently but in JUNE (or at June DEBUG was enabled) :

[24-Jun-2019 12:12:05 UTC] PHP Warning: session_start(): open(/var/cpanel/php/sessions/ea-php56/sess_797478b92aacdbc0d655e7c4a9b8a0ad, O_RDWR) failed: No such file or directory (2) in /home/thegre/public_html/wp-content/plugins/wpforo/wpf-includes/class-notices.php on line 16

Page 1 / 3