Notifications
Clear all

wpForo 1.x.x [Solved] Making the forum wider

8 Posts
4 Users
1 Reactions
1,228 Views
Jesus
Posts: 287
Topic starter
(@jesus)
Reputable Member
Joined: 3 years ago

Hi, apparently I got the forum to a 100% yet its not fullwidth and its a lot less wider than for example this very forum.

*Someone else from DIVI support (where its integrated) has tried setting the forum to a 120% but he says the forum didnt looked good and it destroys its formatting

Is there anyway I could sort this? Even if just at the width you got this very forum

Thanks 🙂

7 Replies
Posts: 14
 Read
(@read)
Active Member
Joined: 3 years ago

Screenshot to the studio

1 Reply
Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4546

@jesus,

That's should be done from your theme side. This page layout is under your Theme control. wpForo only controls the inside layout and style. You should edit the forum page and search for theme layout settings in Edit Page screen. If those don't allow you to change the page layout, you should insert custom CSS. We can help with custom CSS, just leave some URL to your forum page.

Posts: 1162
(@percysgrowroom)
Noble Member
Joined: 5 years ago

Have tried setting the page your using for the forum to full width, no sidebars? Then this will display wpforo with the forum side bar. You have the forum set to 100% and it should all work good. 

 

You can adjust the size of the forum side bar if thats the issue, but as long as the page that has the forum on is full width with no side bars there shouldn't be an issue. 

Link to your site? 

Jesus
Posts: 287
Topic starter
(@jesus)
Reputable Member
Joined: 3 years ago

Thanks every1

Divi (elegant themes) works in modules. I don't think, or I don't know how I could include "a shortcodes to the forum perhaps"?????? within one of this Divi full width boxes. I don't think this is possible plus I'm almost sure, Divi staff would have gave me that as an option when he was looking yesterday into it

That's about the desktop view

In the mobile view for instance, despite I have a code that expand "my normal website content to a 90%, when we go to the forum, once again you can see the forum it's no bigger than 80%

*With Divi mobile content shows at an 80% but again remember that I have a code to override this

My site under construction has only two pages so I rather give you the main and from there you click in the button forum. Thanks very much in advance

Mundo Piano (Piano World)

 

 

 

1 Reply
Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4546

@jesus,

Use the CSS code below:

.container {
    max-width: 100% !important;
    width: 89%  !important;
}

The red marked value can be changed as you like. 

The CSS code should be added in the "Custom CSS code" textarea, located in the Dashboard > Forums > Settings > Styles Tab.  

Don't forget to press Ctrl+F5 (twice) on the forum frontend before checking to reload the updated CSS file. 

Jesus
Posts: 287
Topic starter
(@jesus)
Reputable Member
Joined: 3 years ago

WOW, fantastic thanks 🙂

It worked inmediately, didnt even have to press the reload twice. And even better, it has affected my "normal header" outside within the Forum 🙂 and its starting to look superb before that its as said, just started 🙂

Just one more thing please, which I think its fine but just in case.... I have added said code BELOW the code that was already written in that very box which is:

#wpforo-wrap {
font-size: 13px; width: 100%; padding:10px 0; margin:0px;
}

Correct?, Thanks so much once again 🙂

1 Reply
Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4546

@jesus,

everything is correct. We'll mark this as solved.