Notifications
Clear all

wpForo 1.x.x [Closed] My Profile Breaks Theme

6 Posts
3 Users
2 Reactions
1,753 Views
Estacey19
Posts: 8
Topic starter
(@estacey19)
Active Member
Joined: 5 years ago

This happens even on your site -  When you press the My Profile menu item -  the Profile top  moves up under the Header - forcing the user to roll the mouse wheel down to see the Menu bar and/or header. 
   This happens on my site,  and it's very annoying. 

5 Replies
Robert
Posts: 10534
Admin
(@robert)
Support Team
Joined: 8 years ago

Yes, this is designed to work that way. The profile page header is big so it automatically moves your screen to the profile tab content. If you click on Activity menu you're going to see Activities not the top menu so it's better to scroll your view to activities. Without this function you'll always see your website header and scroll it bottom.

Estacey19
Posts: 8
Topic starter
(@estacey19)
Active Member
Joined: 5 years ago

I appreciate your answer that the software was 'designed' to act that way.   So,  What can I do to make it look like this (my header doesn't disappear like yours does) -    I would like the entire forum to remain in the block it's been assigned by my theme  (Gecko)...  

3 Replies
Estacey19
(@estacey19)
Joined: 5 years ago

Active Member
Posts: 8

I understand you aren't interested in helping me achieve the profile alignment I asked about?     How do you PREVENT the profile from rolling up and under header menu?

Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4543

Hi @estacey19,

Sorry for the late response. As Robert already mentioned it's designed to work in this way. If you'd like to change this, please follow the steps below:

1.Into your active WordPress theme create new folder named /wpforo/ .

2.copy the profile.php file, located in /wp-content/plugins/wpforo/wpf-themes/classic/ to wp-content/themes/yourtheme/wpforo/ folder

More info in this doc in this doc: https://wpforo.com/docs/root/forum-themes/theme-customization/

In the the wp-content/themes/yourtheme/wpforo/ profile.php file find this id="m_" code and remove it. 

 

Estacey19
(@estacey19)
Joined: 5 years ago

Active Member
Posts: 8

That was 'EXACTLY' what I was looking for,  thank you for ability to change that.

Perhaps it could be a 'Switch' to turn on or off in the future.. It looks 'so much better'...