Notifications
Clear all

wpForo 1.x.x [Closed] Problem accessing Forum from Android phone

4 Posts
2 Users
0 Reactions
673 Views
Posts: 34
Topic starter
(@faitht)
Trusted Member
Joined: 5 years ago

Hi there,

Yesterday I had a user who could see the forum, but when she clicked on a category or topic, she got thrown to another page on the site (our sign up for the newsletter page).  After I tried setting her up a new user profile said she could use the forum on her laptop but not on her Android phone. 

Now today I have  another woman with the same issue and I would be very grateful for any thoughts on how to fix this, as this one doesn't have a laptop to fall back on.

The forum is part of a course on this website https://sharonblackie.net and is protected by Memberpress. I would need to set you up as a test user if you need to look into the forum page so would need an email address to do that.

I don't think the Memberpress plugin can be the issue as I have exactly the same setup on two other sites and the forums are working perfectly. 

I'm very grateful for your help!

Thanks

Faith

3 Replies
Robert
Posts: 10545
Admin
(@robert)
Support Team
Joined: 8 years ago

Hi @faitht,

This is another common problem made by website designers and developers. wpForo works fine and you're searching problem in wrong place. You have some VERY BAD CSS in your website.

I don't know it's your CSS or it comes from the theme. But it's hides the main wrapper of content when screen size becomes less than 766px. Please remove this code:

@media only screen and (max-width: 980px) and (min-width: 768px){
   .wpforo .et_pb_section_1 {
         display: none!important;
  }
}

@media only screen and (max-width: 766px){
  body.wpforo .et_pb_section_1 {
       display: noneimportant;
   }
}

We found it in this CSS file:

https://sharonblackie.net/wp-content/cache/et/5690/et-core-unified-15718232819.min.css

Once you removed this code, please delete autoptimizer cache and use mobile browser private session to check it. The regular browser keeps very hard cache so you'll not be able to see changes. After each change you should use a new private session tab in browser.

2 Replies
Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10545

Once those codes are removed please add these CSS code in Forums > Settings > Styles > Custom CSS Texarea. Save, delete all caches and use the same private session mode to check it.

@media only screen and (max-width: 980px) and (min-width: 768px){
.wpforo .et_pb_section_1 {
display: block !important;
}
}

@media only screen and (max-width: 766px){
body.wpforo .et_pb_section_1 {
display: block !important;
}
}

@media only screen and (max-width: 980px) and (max-width: 767px){
.wpforo .et_pb_row .et_pb_column .et_pb_module:last-child{
display: none!important;
}
}
(@faitht)
Joined: 5 years ago

Trusted Member
Posts: 34

@robert

Hi Robert,

Thank you so much for your quick reply. 

That's not my CSS - I only wrote a few lines of styling.

That must have been added to the theme when I added the WP Foro plugin. I don't know where to look to get rid of that code! I think I need to write to Elegant Themes for help as it looks like it's part of the core Divi code.

Please can we keep this post open so that I can come back to you once I've done everything - just in case I get stuck?

thanks again

Faith