Notifications
Clear all

wpForo 1.x.x Read-only access rights don't seem to be working as expected

5 Posts
2 Users
0 Likes
1,719 Views
GJC1
Posts: 22
 GJC1
Topic starter
(@gjc1)
Eminent Member
Joined: 6 years ago

I've configured read-only access to allow unregistered people to view topics but not replies (as shown in "read only access settings" in the attached file

But an unregistered user is still able to view replies as shown in "viewing replies"

Am I doing something wrong or is there a problem in how access rights are being managed?

Thanks, Graham 

4 Replies
Robert
Posts: 9354
Admin
(@robert)
Support Team
Joined: 6 years ago

You should use "No Access" instead of "Read Only". "Read Only" means that user or guest can view and read. If you don't want them to read/view you should set them No Access.

Reply
GJC1
Posts: 22
 GJC1
Topic starter
(@gjc1)
Eminent Member
Joined: 6 years ago
Posted by: Robert

 

You should use "No Access" instead of "Read Only". "Read Only" means that user or guest can view and read. If you don't want them to read/view you should set them No Access.

   

But I modified the Read Only settings (as per screenshot in my original zip file) to preclude access to replies. Shouldn't that have done what I was hoping?

Reply
Robert
Posts: 9354
Admin
(@robert)
Support Team
Joined: 6 years ago

wpForo doesn't support topic subComponent restriction yet. We're currently improving this. If you want to close access to replies you should class access to Topic ass well. So please uncheck the View Forum and View Topic CAN too, in other words just use already configured read-only access. There is no other ways at the moment. The subComponent restriction will be available in a few releases.

Reply
GJC1
Posts: 22
 GJC1
Topic starter
(@gjc1)
Eminent Member
Joined: 6 years ago

Thanks Robert

Appreciate the guidance - and look forward to this additional functionality.

Reply
Share: