Notifications
Clear all

wpForo 1.x.x SEO Text in Browser Tab

5 Posts
3 Users
0 Likes
1,333 Views
Slicky
Posts: 10
Topic starter
(@slicky)
Active Member
Joined: 5 years ago

Hi,

I would like to know, how and where I can change the SEO Text in the Browser Tab?

Example: Main Page Browser Tab is showing: Dein Assistent rund ums Smarthome - SmarthomeAssistent

Example: Forum Browser Tag is just showing the URL:  https://www.smarthomeassistent.de/forum/

I would like to change that Text to Forum - SmarthomeAssistant or something similar.

I already tried the settings from the Site Page where the Forum site is hosted and also i the Forum settings.

I use Yoast, if this is relevant to you.

 

Kind regards, Karim.

4 Replies
Robert
Posts: 9256
Admin
(@robert)
Support Team
Joined: 6 years ago

wpForo doesn't display site URL in tab, wpForo is designed to display SEO friendly titles like you see on this forum. There is some problem on your website, it's whether conflict with other plugins or your theme doesn't have standard hook to change page meta title. Try to deactivate all SEO plugins, delete all caches and test it again. Then change the theme and test it again.

Reply
Anonymous20
Posts: 1602
(@anonymous20)
Noble Member
Joined: 6 years ago

... and disable Rocket cache for all wpForo urls (/forum*)

Reply
Slicky
Posts: 10
Topic starter
(@slicky)
Active Member
Joined: 5 years ago

Thanks!

Okay, I disabled the Rocket Cache for "/forum". 
Didn't change anything 🙁 

It's no option to disable my Yoast SEO Plugin 🙁 Also to change the Theme is no Option.
Any other sugestions?

Kind regards, Karim.

Reply
Robert
Posts: 9256
Admin
(@robert)
Support Team
Joined: 6 years ago

Could you please try to add this code in WordPress active theme's functions.php file?

add_filter( 'pre_get_document_title', 'wpforo_meta_wp_title', 100);

Then delete all caches and do Ctrl+F5 on forum front.

Reply
Share: