Notifications
Clear all

wpForo 1.x.x User groups and forum access types

7 Posts
3 Users
0 Likes
2,929 Views
mands
Posts: 4
Topic starter
(@mands)
New Member
Joined: 5 years ago

Hi.

I've just installed wpforo and it's sort of working.

First issue is I don't want guests to see anything but I can't see where I associate usergroups with forum access types.

I can see from Settings -> Forum Accesses that Guests have Read only access but I can't see where to move them to No access.

A nudge in the right direction would be appreciated.

Thanks.

6 Replies
Robert
Posts: 9713
Admin
(@robert)
Support Team
Joined: 7 years ago

You should set Accesses to Usergroups for each Forum. Just edit the forum and manage Usergroup - Access settings, set it Guest <> No Access:

By default all forums permissions are set Guest <> Read Only.

For quick setting you can edit the Read Only access and disable all permissions. So you'll not have to edit each forum and set No Access for Guests.

Reply
1 Reply
Denny
(@denny)
Joined: 3 years ago

New Member
Posts: 2

@robert

I have set Guest to No access as you outlined above and saved it.  Then I opened an incognito window in another browser where I'm not logged in to test it, went to the forum page and I could still see the forum and individual posts.  I have spent several hours trying to remove access for anyone who is not logged in, but have not been able to do it.  Please help.

Reply
mands
Posts: 4
Topic starter
(@mands)
New Member
Joined: 5 years ago

Many thanks.

Is there some way to make this a default for new forums?

Thanks.

Reply
Robert
Posts: 9713
Admin
(@robert)
Support Team
Joined: 7 years ago

Please explain what do you mean saying "this" and "new forums". if yo create a new forum all settings are on the right sidebar, that's not hard to change before saving the forum.

Reply
mands
Posts: 4
Topic starter
(@mands)
New Member
Joined: 5 years ago

Sorry for delay.

I just want to make sure that it's fail safe so the default permission for new groups is everyone has no access. Then all access has to be explicitly granted.

Thank you.

 

Reply
Page 1 / 2
Share: