Notifications
Clear all

[Solved] Why can't I change my wpForo menu?

8 Posts
2 Users
1 Likes
665 Views
Posts: 12
Topic starter
(@loehoafaq)
Active Member
Joined: 1 year ago

My WP site displays a menu, and I don't understand where it's coming from. As can be seen in the attached screenshot, I've deleted the wpForo default menu and created a new one, saved it and published it but a different menu is still displayed despite forcing a reload in my browser. The strange thing is, it's not even the default menu that I deleted. I can't figure out where it's coming from.

I'm a new WP user, have been through all the menus and searched for reports of similar problems. I disabled the built-in wpForo cache in the hope that was the problem but still see the same menu.

I have the following WP plugins installed in addition to wpForo, all the latest versions:

Akismet Anti-Spam

Classic Editor

Forminator

Limit Login Attempts Reloaded

The Events Calendar

Ultimate Member

Visitor Traffic Real Time Statistics pro

7 Replies
Chris
Posts: 3650
(@chris)
Famed Member
Joined: 3 years ago

Hi @loehoafaq,

I guess that's not a menu but your pages, and the reason is that you don't have a menu there, so the theme sets the pages.

You can remove the pages, by creating a new menu, without any link(let it empty) and set its display location to that part of the theme, I guess its Primary Menu location.

Posts: 12
Topic starter
(@loehoafaq)
Active Member
Joined: 1 year ago

Update. I found the page to delete all caches as well as user cache, and I did but the mystery menu is still served. I turned Debug on so if additional info is needed but didn't see anything obviously useful. I am able to use the Site Editor to modify the menu but can't get a menu created using Appearance->Menus to display.

1 Reply
Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@loehoafaq,

what do you mean, you cannot create a menu from Appearance > Menus Admin page? What's the problem that you cannot do it?

Posts: 12
Topic starter
(@loehoafaq)
Active Member
Joined: 1 year ago

Please see the image uploaded with my original post.

1 Reply
Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@loehoafaq,

I see that you use Site editor on the Page, but what kind of problem appears when you try to create a new Menu from Appearance > Menus?

Posts: 12
Topic starter
(@loehoafaq)
Active Member
Joined: 1 year ago

On the left side of the image you can see the custom menu I'd like to display. I created it by going to Appearance->Menus in the WordPress Dashboard, and set its display location to "wpForo Menu", but I see some default menu (perhaps part of the theme?) on my site instead.

I used the site editor to show the actual menu I see on my site.

Page 1 / 2