Migration from WP S...
 
Notifications
Clear all

[Closed] Migration from WP Symposium?

11 Posts
2 Users
0 Reactions
3,421 Views
0
Topic starter

 Has anyone migrated to wpForo from WP Symposium?  If so, what steps did you take?  Is there a map of the database info for wpForo if I need to do it myself?  Thanks, all!

10 Answers
0
Topic starter

I've made a lot of progress on this and I'll be happy to share what I've done once it's finished.  A couple remaining issues:

  1. On the main forum page everything says it was posted by Anonymous.  When I click through to the forums and posts it all looks right, assigned to the right users.  I saw this once before and then it cleared itself up, so I think it's cache related.  I don't have caching turned on, and I've cleared the wpForo caches.  What else should I do?
  2. I've copied user avatars from the old system to the new directory and added the links to them to the wpforo_profiles database table.  They're not getting picked up, though, and showing as broken images.  Are there other steps I need to do to get them to work?

Thanks for your help!

0

Hi Glowball

I'm sorry but there is no migration tool for this yet. You can ask ProfProjects GP for professional migration services: http://profprojects.com/migration-services/#forum

1. On the main forum page everything says it was posted by Anonymous.  When I click through to the forums and posts it all looks right, assigned to the right users.  I saw this once before and then it cleared itself up, so I think it's cache related.  I don't have caching turned on, and I've cleared the wpForo caches.  What else should I do?

You should disable other cache plugins for forum page and enable wpForo cache options (except HTML cache) in Dashboard > Forums > Settings > Features admin page. Then open check your database > _wpforo_forums table and make sure the last_userid  are not empty. This is the reason why you see Anonymous usernames. The last userid-s should also be properly migrated.

2. I've copied user avatars from the old system to the new directory and added the links to them to the wpforo_profiles database table.  They're not getting picked up, though, and showing as broken images.  Are there other steps I need to do to get them to work?

Navigate to Dashboard > Forums > Dashboard admin page and click on [Delete member cache] then click on [Delete all caches] button.

In case you want to say thank you !)
We'd really appreciate and be thankful if you leave a good review on plugin page. This is the best way to say thank you to this project and support team.

Glowball Topic starter 26/07/2017 11:45 pm

The last_userid looks right and I've deleted caches (this is development and I don't have caching enabled) and it's still saying Anonymous.  I'm having a tough time getting avatars to show up, too.  I might have to wait it out.

0

The last_userid looks right

I don't think so. Something is 100% wrong with that. Either there is no id in this field  or there is no User with these IDs in _users and _wpforo_profiles table.

In case you want to say thank you !)
We'd really appreciate and be thankful if you leave a good review on plugin page. This is the best way to say thank you to this project and support team.

0
Topic starter

I double checked and user IDs are correct in all three tables.  With that said, my development site is a little flaky at times so I'm working under the assumption that is the problem.  I'll let you know how it goes in production after the migration.

0
Topic starter

I missed setting the last_post field in the wpforo_topics table -- as soon as I set that it worked.  That issue is resolved.

I'm still not able to add avatars for the 178 people who added them in the old system.  Here's a new symptom.  When I upload an avatar (confirmed to be working in Windows) to /wp-content/uploads/wpforo/avatars and then I set the URL in wpforo_profiles it shows up as a broken image.  The new symptom is that I also cannot load it by going to its URL, even though it exists.  If I upload an avatar through the wpforo utility on the front end, I can load it by going to its URL.  I have no idea why, but I get a 404 error when I try to load manually FTP'd images.

I've seen this before when building a completely different utility, so it's probably not wpforo.  I'm hoping someone out there has seen this before and has some tips, because I have no idea why that's happening.  I'm researching.

Would you like the script I used to migrate from WP Symposium?

0
Topic starter

I've got this issue posted at  https://wordpress.org/support/topic/some-images-giving-404-errors/ too, if anyone's following this topic.

0

Please keep deleting member cache in Dashboard > Forums > Dashboard admin page. I think you got cache issue.

 Also please make sure the folder permissions are 755 and files are 644 in file system:

In case you want to say thank you !)
We'd really appreciate and be thankful if you leave a good review on plugin page. This is the best way to say thank you to this project and support team.

0
Topic starter

Do you think caching would prevent me from directly calling images?  What would be the difference between an image uploaded by wpForo and an image I FTP into the same directory?  Do wpForo images get cached on upload, or is there some other thing happening behind the scenes for those?  I'm having a hard time wrapping my head around it.  Thanks for walking me through this.

0

Please let me know if your issue is fixed. if not please send admin login details to support[at]gvectors.com email address. Also provide with some examples of avatars.

In case you want to say thank you !)
We'd really appreciate and be thankful if you leave a good review on plugin page. This is the best way to say thank you to this project and support team.

0
Topic starter

I haven't been able to fix it.  I'll send that email, thanks.