Notifications
Clear all

[Solved] Moderation stopped working

17 Posts
4 Users
2 Reactions
1,010 Views
Posts: 49
 Joel
Topic starter
(@joel)
Trusted Member
Joined: 8 years ago

All of the sudden out moderation stopped working.

We used to have it setup where new users had to do 5 posts that where held for moderation.  Then we changed the user groups and selected Front - Can pass moderation.   Later we took the checkmark out of Font-Can pass moderation.

Now nothing is being moderated.... it's all just getting auto-approved.

Any other trouble shooting we can do here?

16 Replies
Robert
Posts: 10519
Admin
(@robert)
Support Team
Joined: 8 years ago

@joel,

Please check the following steps:

1. Make sure the new registered user gets correct user role and usergroup. The default user role is set in WordPress Settings > General admin page, and the default usergroup is set in wpForo > Usergroups admin page.

2. Edit the default usergroup in wpForo > Usergroups admin page and DISABLE "Front - Can pass moderation" permission. It should be unchecked.

3. Go to wpForo > Settings > Spam Protection Tab and update the following options:

  • Enable wpForo Spam Control: Yes
  • Ban user when spam is suspected: No
  • Spam Suspicion Level for Topics: 47
  • Spam Suspicion Level for Posts: 56
  • ---
  • User is New (under hard spam control) during first [X] posts: 5
  • Posts must be manually approved: Yes
  • Min number of posts to be able to edit profile information: 3

 

4. Go to wpForo > Overview admin page, scroll down and click the [Delete Users Cache] button.

Posts: 49
 Joel
Topic starter
(@joel)
Trusted Member
Joined: 8 years ago

I wish I could tell you that worked... but it didn't.

I've spent about 2 hours now trying it over and over.  I even turned off the sync and double and triple checked the settings.

I think moderation is broken on our site or in your plugin right now? 

Is it working for others?

2 Replies
Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10519

@joel,

You're doing something wrong for sure. It would be better to check this issue directly on your site. Please send the admin login details to support[at]gvectors.com email address.

(@superneelio)
Joined: 8 years ago

Active Member
Posts: 8

Hey @robert 

We have setup the forum as directed and moderation is still not working (image attached)

 

Do you have any more troubleshooting steps we can take?

Posts: 8
(@superneelio)
Active Member
Joined: 8 years ago

Usergroup image

Posts: 49
 Joel
Topic starter
(@joel)
Trusted Member
Joined: 8 years ago

Yes see SuperNeelio's screenshot we have all the settings as you say.  Moderation does not work.  I think we have now spent about 4 hours on this.  

Is there anything else that affects if Moderation works.

One thing you guys might want to consider is separating the Spam Feature with the moderation feature as I see them as completely different things.

Just make a feature that says "Moderate All Posts", Moderate certain users posts"

Just a suggestion.

We really need to get this feature working but we can't give anyone outside admin access to our system so any other suggestions would be helpful

 

3 Replies
Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10519

@joel,

1. Are you sure the posts are not unapproved? It seems the "Awaiting moderation" message was changed or hidden. Why you think the posts are not set unapproved. The post which are waiting for moderation should have [Approve] button or icon, if you see this then the post is waiting for approval:

 

2. Do you know that the moderation only works for the users with "New user" status? Maybe the user you're checking has more than X number of posts, which is set for the "User is New (under hard spam control) during first [X] posts" option in Spam Protection settings.

 

3. Are you sure you don't have custom code or custom template file in the WordPress active theme directory related to wpForo?

 

4. Have you tried to temporally disable other plugins? This could be a plugin conflict.

(@superneelio)
Joined: 8 years ago

Active Member
Posts: 8

Hey @robert 

We often use the moderation tab under the WPForo menu. We have new users joining almost daily and they are not being held in moderation.

We haven't installed any new plugins and it was working up until we increased the number of posts kept in moderation to 5 and then it broke.

 

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10519
Posted by: @superneelio

we increased the number of posts kept in moderation to 5 and then it broke.

What does this mean?

Page 1 / 2