Notifications
Clear all

wpForo 1.x.x [Closed] 404 Errors on New Install

10 Posts
2 Users
0 Likes
3,198 Views
Saluki
Posts: 29
Topic starter
(@saluki)
Eminent Member
Joined: 6 years ago

Greetings all.  I have installed the wpForo plug-in per the instructions in the documentation.  No issues with the actual install.  However, when I click any link to preview one of the built-in start-up forums I get a 404 error with the following message:

The requested URL /app.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Does anyone have suggestions on how to resolve this issue?  My searches have come up empty.  Thank you!

9 Replies
Robert
Posts: 10503
Admin
(@robert)
Support Team
Joined: 8 years ago

Hi Saluki,

Please make sure you don't use the default ?p=1 permalink structure in Dashboard > Settings > permalinks admin page.

Also please explain what is /app.php ? Don't use use a normal WordPress? Could you please disable other plugins?

1 Reply
Saluki
(@saluki)
Joined: 6 years ago

Eminent Member
Posts: 29

Hi Robert,

Thanks for the fast response.  The permalink setting is set to the "Month and name" option, so we are good there.

I have no idea what /app.php is in reference to.  Right now I am looking at the Categories and Forums page in the control panel.  When I click the eye on the far-right side of the first category bar in order to preview, this is when I get the 404 error and the message about /app.php.  The link wpForo assigned is http://mydomain.com/community/main-category

Perhaps a host issue?  All of the back-end configuration pages work just fine.  I can publish the forum to the web and everything looks great.  It's just when you click on any link they all resolve to the 404 error. 

  

Robert
Posts: 10503
Admin
(@robert)
Support Team
Joined: 8 years ago

Please leave a URL to forum home page. Also I asked to disable all plugins, delete cache and test it. Please do that as well.

1 Reply
Saluki
(@saluki)
Joined: 6 years ago

Eminent Member
Posts: 29

Sorry about that.  All plug-ins except wpForo disabled.  All cache cleared.

I reactivated the forum site at http://saluki-insider.com

 

Saluki
Posts: 29
Topic starter
(@saluki)
Eminent Member
Joined: 6 years ago

Additional info...the "Register" and "Login" links seem to work properly. 

Robert
Posts: 10503
Admin
(@robert)
Support Team
Joined: 8 years ago

Please navigate to Dashboard > Forums > Settings admin page and click on Update Options button.

Make sure you have the trailing slash on end of the permalink structure in WP settings.

If this doesn't work, please disable the "Turn wpForo to WordPress" option, Then Uninstall (not deactivate) and install wpForo again. The uninstall will remove all forum data and rest it on new installation.

Page 1 / 2