Notifications
Clear all

wpForo 1.x.x [Solved] 404 - Page not found

19 Posts
4 Users
0 Likes
2,294 Views
Posts: 9
Topic starter
(@ramonaforever6661)
Active Member
Joined: 4 years ago

Hi, I recently updated to version 1.6.2 and now when clicking on the forum page on my website, I'm just met with:

404

Oops! The page you requested was not found!

I've been through every troubleshooting checklist I can find in the support threads and just exhausted every option including uninstalling/reinstalling but nothing has worked so far. Any ideas?

18 Replies
2 Replies
Muhammad Umar Farooq
(@pkheart)
Joined: 4 years ago

Eminent Member
Posts: 32
Posted by: @ramonaforever6661

Hi, I recently updated to version 1.6.2 and now when clicking on the forum page on my website, I'm just met with:

404

Oops! The page you requested was not found!

I've been through every troubleshooting checklist I can find in the support threads and just exhausted every option including uninstalling/reinstalling but nothing has worked so far. Any ideas?

same issue for me, when i add any attchment in post "error 404" occurs.

after changing media attachment setting issue resolved.

Settings>Features>Insert Forum Attachments to Media Library to "NO".

Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9966

@pkheart

I don;t think they are related. And I don't think this option has any relation to 404. When you change an option you also delete all caches so I think your issue was the cache, and after deleting the cache problem is fixed.

Robert
Posts: 9966
Admin
(@robert)
Support Team
Joined: 7 years ago

@ramonaforever6661,

Please deactivate and activate wpForo again. Then navigate to Dashboard > Forums > Settings > general tab, make sure the base URL is correct and click on [Update options] button. Then navigate to Dashboard  >Settings > Permalinks admin page, and make sure you use WordPress permalinks, update those too.

13 Replies
(@ramonaforever6661)
Joined: 4 years ago

Active Member
Posts: 9

@robert

Thank you for your reply. I've just run through that list and all seems to be in order but still seeing the error. Any other suggestions?

Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9966

@ramonaforever6661

Could you please leave your forum URL?

(@ramonaforever6661)
Joined: 4 years ago

Active Member
Posts: 9
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9966

@ramonaforever6661

  • Could you please explain why it redirects to /communityforum/ page when I call /community/ ? Have you setup any redirection rules?
  • What is the forum page slug/url?
  • What is the Forum base URL in Dashboard > Forums > Settings Page?
  • Why your website contains "~" in URL? Could you please test it on real website?
(@ramonaforever6661)
Joined: 4 years ago

Active Member
Posts: 9

@robert
I tried changing the Base URL to see if the issue was the standard 'community' URL. It currently matches the page URL, so that shouldn't be an issue. It didn't work as the standard 'community' URL either. 

The forum slug is 'communityforum', as is the base URL in the Forums dashboard. 

The website is a temporary URL while I wait to transfer the domain over. The previous version of wpforo worked perfectly on my website until updated to 1.6.2 and then this error started.

Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9966

@ramonaforever6661

Please deactivate this version, delete it and install the previous 1.6.1 version. I need to see how it works. This will not affect any data, so do not worry.

(@ramonaforever6661)
Joined: 4 years ago

Active Member
Posts: 9

@robert

This version works! There must be a compatibility issue between my site and version 1.6.2. How strange! 

(@anonymous20)
Joined: 7 years ago

Noble Member
Posts: 1602
Posted by: @ramonaforever6661

@robert

This version works! There must be a compatibility issue between my site and version 1.6.2. How strange! 

Actually Disable this and try again:

<!--Generated by Endurance Page Cache-->

 

Also as Robert said something is very wrong in your setup, the base forum url and their navigation.

(@ramonaforever6661)
Joined: 4 years ago

Active Member
Posts: 9

@anonymous20

I'm not sure how to disable that. The previous version works with no problem? 

(@anonymous20)
Joined: 7 years ago

Noble Member
Posts: 1602
Posted by: @ramonaforever6661

@anonymous20

I'm not sure how to disable that. The previous version works with no problem? 

Ask your hosting provider how to disable. If it is a plugin IN your Wordpress disable/remove it. 

Also install it to a real domain and check. This url (temp) is a bit strange and could cause some problems.

(@ramonaforever6661)
Joined: 4 years ago

Active Member
Posts: 9

@anonymous20

Thank you for your help. I will be moving the site to a real domain as soon as it is available to transfer to my host. I'm a bit new to all this website business so thank you for your patience and explanations. For now it seems to be working again 🙂 

(@anonymous20)
Joined: 7 years ago

Noble Member
Posts: 1602
Posted by: @ramonaforever6661

@anonymous20

Thank you for your help. I will be moving the site to a real domain as soon as it is available to transfer to my host. I'm a bit new to all this website business so thank you for your patience and explanations. For now it seems to be working again 🙂 

There is plenty of information how to disable Endurance cache (are you on BlueHost ?). Just google it.

(@ramonaforever6661)
Joined: 4 years ago

Active Member
Posts: 9

@anonymous20

Yes, I'm using Bluehost. Thank you, I will try that in a minute!

Posts: 1602
(@anonymous20)
Noble Member
Joined: 7 years ago
1 Reply
(@ramonaforever6661)
Joined: 4 years ago

Active Member
Posts: 9

@anonymous20

Thank you. I was in the middle of switching everything back over to the 'community' slug/base URL. That should all be in working order now.