Notifications
Clear all

New Feature [Closed] 504 Error when publishing a message

20 Posts
3 Users
0 Reactions
1,703 Views
Posts: 75
Topic starter
(@maxelio42)
Estimable Member
Joined: 5 years ago

Hi,

We just opened our site for our members, and have many recurrent error messages, with

"504 Gateway Time-out - The server didn't respond in time"

, when clicking on the button to publish a message.

Do you have an idea of what leads to this error?

Could it be related to the plugin itself, or its relation with another one?

For your information, we use Post SMTP plugin to send the "new forum message" notification emails to our members.

Many thanks for your help, we are in dire straits!

Best regards,

19 Replies
Posts: 1602
(@anonymous20)
Noble Member
Joined: 8 years ago
Posts: 75
Topic starter
(@maxelio42)
Estimable Member
Joined: 5 years ago

Hi Anonymous20,

Thanks for your reply, but to be more precise on the issue, we have two forums on our site :

- one forum is private and used by 17 persons : no 504 error in this forum when publishing a message, and a normal time to validate a new message.

- the other forum is opened to every users, around 2000 persons, and everyone has subscribed to every message, so many notifications emails are send through POST SMTP each time a new message is published.
It is in this forum that we have this issue, with a VERY long time after you validate the new message.

That's what make me say that it could perhaps be related to the time needed to send all these notification emails.

In other words, at what time does the SMTP sending process give back hand to Wpforo? And this lapse of time, if too long, could it be counted as a "timeout" by the system, and generate this error?

 

Posts: 1602
(@anonymous20)
Noble Member
Joined: 8 years ago

That make some sense, but even so it is a hosting problem. A slow "way" to send emails. Smtp sends directly the emails or routes them to a mail server ?

 

 

Posts: 75
Topic starter
(@maxelio42)
Estimable Member
Joined: 5 years ago

I thought that the time necessary for POST SMTP to treat a large quantity of emails and send them to the SMTP server could be a part of the problem, and so that this problem could find a solution locally (perhaps a SMTP plugin more efficient or a CRON service, or a parameter to change in WPForo), am I wrong?

Concerning the SMTP route, I don't know, I suppose I should ask my provider (INFOMANIAK)...

You talk about a "slow way", do you know faster ways to send this notification emails, that could solve my issue?

And by the way, how is THIS forum managed concerning the sending of these emails?

Page 1 / 2