Notifications
Clear all

wpForo 1.x.x [Closed] Admin Cant see forums

6 Posts
3 Users
0 Reactions
644 Views
Posts: 3
Topic starter
(@haxiboy)
Active Member
Joined: 4 years ago

Hello!

One of my customers have a problem with forums.

The problem possibly be permission related, but no permission changes were mage.

The issue is with the first wordpress user (main admin). On the forum permissions page i can see one user is associated with administrator role, but this user is actually not listed, and this user has no access to the forums except the administration on the dashboard.

 

Any advice appreciated!

 

Regards

Peter

 

5 Replies
Alvina
Posts: 1867
Moderator
(@alvina)
Member
Joined: 5 years ago

Hi @haxiboy,

The issue is with the first wordpress user (main admin). On the forum permissions page i can see one user is associated with administrator role, but this user is actually not listed...

It seems there is a cache issue. 

Please navigate to the Dashboard > Forums > Dashboard admin page, click on "Delete User Cache"  then "Delete All Caches" button and check again.

Also please read this  FAQ topic to get more info about wpForo Usergroups, Forum Accesses and WordPress User Roles: https://wpforo.com/community/faq/wordpress-user-roles-wpforo-usergroups-and-forum-accesses/

3 Replies
(@haxiboy)
Joined: 4 years ago

Active Member
Posts: 3

Hi @alvina

 

This was the first one i've tried, but sadly nothing changed. I've updated the plugin, but still no effect.

I've found that on user's settings i can turn on secondary groups for Registered user.

Admin role has all permissions, on usergroups it shows that everything is in sync.

I've updated WP to the latest release but still no luck.

 

Regards

Peter

(@haxiboy)
Joined: 4 years ago

Active Member
Posts: 3

I've just noticed that user with ID 1 is also missing from the members of forum.

Alvina
Moderator
(@alvina)
Joined: 5 years ago

Member
Posts: 1867

@haxiboy,

Please navigate to the Dashboard > Forums > Forums admin page, edit each forum and make sure for the admin usergroup forum permission is set "Full access" and check again. See the screenshot below:

 forum_permission.png

I've just noticed that user with ID 1 is also missing from the members of forum.

Please navigate to the Dashboard > Forums > Usergroups edit the current usergroup and make sure the "Display on Members List" option is checked and check again.

Robert
Posts: 10534
Admin
(@robert)
Support Team
Joined: 8 years ago

Hi @haxiboy,

The 1.8.2 is released. Please update, then delete all caches. Then logout and login again and check the issues. If you see any problem please test another time with an incognito / private session of browser then report the issue in the release topic.