Notifications
Clear all

wpForo 1.x.x [Closed] "Cannot modify header information" conflict with BuddyBoss>Forum Discussions

7 Posts
3 Users
1 Reactions
1,143 Views
Posts: 6
Topic starter
(@macfionn)
Active Member
Joined: 3 years ago

Occurs when creating a new post. The post IS created, but you have to go back a page and refresh to see it.

(PS..I DID search the forum before posting. 🙂  )

Warning: trim() expects parameter 1 to be string, array given in /home/customer/www/.com/public_html/wp-includes/class-wp-query.php on line 782

Warning: strip_tags() expects parameter 1 to be string, array given in /home/customer/www/.com/public_html/wp-includes/formatting.php on line 2227

Warning: Cannot modify header information - headers already sent by (output started at /home/customer/www/.com/public_html/wp-includes/class-wp-query.php:782) in /home/customer/www/.com/public_html/wp-includes/pluggable.php on line 1329

 

I have Buddyboss>Forum Discussions turned on so that my GROUPS can have their own forum, so its not an option to turn off. That said, if I DO toggle off the Forum Discussions option the error is no longer present.

Can you offer a suggestion, edit, etc that can help me get past this? Ive already bought plugins for WPForo and don't want to abandon it as it is a MUCH better forum for the site at large (other than GROUPS, as I haven't found a way to make WPForo to allow groups their own private forum and it SHOW in the group, as well.)

 

 

 

Forum Discussions

6 Replies
Robert
Posts: 10525
Admin
(@robert)
Support Team
Joined: 8 years ago

Hi @macfionn,

Please note that wpForo doesn't have any integration with BuddyBoss. There is no option with "Buddyboss" name in wpForo. wpForo is integrated with BuddyPress. BuddyBoss is a paid 3rd party solution that we don't support and have not tested any integration. Moreover, I don't see any error from wpForo plugin in the error list.  The errors don't come from wpForo plugin files so the problems cannot be fixed from wpForo side.

In any case, I think there are lots of conflict maker in your website. I'd recommend create a clean  fresh WordPress website with the native Wordpress theme, then install wpForo + BuddyBoss without any other addons. If you still see errors contact to BuddyBoss support team.

Posts: 6
Topic starter
(@macfionn)
Active Member
Joined: 3 years ago

Robert? I didnt pretend to assume that WPForo is built around BuddyBoss! I found an issue and asked for help regarding it. Its a header conflict! I merely assumed someone here would care to be helpful and offer a REAL solution. Very sorry that this appeared to trigger you.

 

Secondly... "Moreover, I don't see any error from wpForo plugin in the error list." You'll notice that there aren't any errors from BuddyPress in the list either!

Third......BuddyBoss is a FREE plugin found on the wordpress.org repository. it is a FORK of Buddypress with many bug fixes that buddypress does not have.  If you want a pro addon that will add zoom features, then sure... you can pay for that. But buddyboss isn’t simply a cosmetic overhaul of buddypress. It has hundreds of bug fixes that that buddypress has never worked out and rectified. it has plugins that were actually combined to promote less resource hogging. its tighter and faster. and yet STILL FREE.

And Lastly... you are again incorrect in assuming my site has "lots of conflict maker in your website". Its a fresh build of buddyboss (FREE VERSION), 2021 template, and WPFORO! THATS IT!  And seeing as how I stepped through the EXACT point where it fails, you make a broad claim that doesn't exactly hit the mark.

I was very understanding that WPForo isnt at fault. But neither is BuddyBoss! Its a conflict between the two and I was ONLY asking for help in finding a work around.

But if this is how you talk to people and "Help" them, I think I can stop my wpforo plugin buying RIGHT here.

 

 

 

dimalifragis
Posts: 2610
(@dimalifragis)
Famed Member
Joined: 4 years ago

"header" errors could be from code (white space for example) you have added or changed somewhere. Have you?

Also please follow Robert's suggestion, a bit differently if you like. Disable all plugins except wpForo and Buddyboss. And check.

Also try a different theme.

btw: Health report anything in error?

3 Replies
(@macfionn)
Joined: 3 years ago

Active Member
Posts: 6

Addendum: fresh installs, so no code changing on my part.

 

@dimalifragis Thank you for the reply.. but again, I only have BuddyBoss, 2021 theme and wpforo installed. Its a fresh install for the very purpose of tracking down the issue. Thats why I know exactly that it only happens when BuddyBoss' "Forum Discussions" is toggled on, and when creating a new post in WPForum.

 

The health report is clean. and it happens on 2020 theme as well (retested)

I found this hoping it could clarify the issue, but didnt fully...

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2610

@macfionn This is why i asked if your did ANY manual modification to ANY code. And you answered that you didn't (or i got it wrong).

This is what the link says ...

(@macfionn)
Joined: 3 years ago

Active Member
Posts: 6

@dimalifragis No sir. You understood correctly. These are clean and untouched straight from the authors. 🙂