Notifications
Clear all

wpForo 1.x.x Can't creat my page

2 Posts
2 Users
0 Likes
1,655 Views
vincitytaymodaimo
Posts: 1
Topic starter
(@vincitytaymodaimo)
New Member
Joined: 4 years ago

Hi, I am surprised the problem I have is not discussed anywhere (or maybe finding it is hard).

I installed wpforo and I managed to put the forums page as my home page. Furthermore, the plugin correctly set up the /community page so I can see all my forums.

The problem is as soon as I click on a forum it does not show up: 404 Oops! The page cannot be found!

When I add a forum with the shortcode the forum shows up but I get a different permalink:

— On /community the link points to /community/forum1
— In the custom page the slug is then just /forum1

It correctly redirects but seems wrong too me.

The same procedure happens when adding new topics. I always have to add the pages manually with shortcodes.

How did I misconfig my installation?

 

1 Reply
Robert
Posts: 9321
Admin
(@robert)
Support Team
Joined: 6 years ago

@vincitytaymodaimo,

You've mixed all and it's hard to fix this. I don't know how many forum pages you have, what is your forum base URL and what page is set as home page in Dashboard > Settings > Reading admin page. Please provide more information and screenshot of the Dashboard > Forums > Settings > General Tab.

Make sure you have two forum pages. The main page should have /community/ slug, the second page should be set as home page in Dashboard > Settings > Reading admin page. The base URL of wpForo should be the same as the main forum page /community/

More info here: https://wpforo.com/docs/root/getting-started/forum-page/set-forum-on-home-page/

Make sure you don't enabled "Turn WordPress to wpForo" option.

Reply
Share: