Notifications
Clear all

[Solved] created new role to limited who can view members, but it's not working

9 Posts
2 Users
1 Likes
2,476 Views
Posts: 23
Topic starter
(@highisland)
Eminent Member
Joined: 4 years ago

Hi Everyone,

I want to limit who can view the member list only to those users who have posted more than 25 times in the forum.  I created a new wpForo user group called Adventurers and created a new WordPress user role with the same name.  I assigned the Adventurers WP role to the Adventurers user group.  I then went to the wpForo group settings and unchecked "can view members".  I assigned myself to this group, but I can't see the member list.  Any idea why it is not taking?

8 Replies
Chris
Posts: 3650
(@chris)
Famed Member
Joined: 3 years ago

Hi @highisland,

I assigned myself to this group, but I can't see the member list.

I guess you wanted to say you can see the Members List.

 

Create a new User and assign him to that usergroup, and check again, and make sure that the user doesn't have a secondary usergroup which allows seeing the Members List.

Posts: 23
Topic starter
(@highisland)
Eminent Member
Joined: 4 years ago

Hi Chris,

Sorry I wrote that wrong.  The Adventurer group should be able to view the member list.  The Customer group shouldn't.  I assigned my user to the Adventurer group but I can't see the member list when I would expect to be able to.  

Andrew

1 Reply
Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@highisland,

Please provide a screenshot of The Adventurer usergroup CAN's(options).

Posts: 23
Topic starter
(@highisland)
Eminent Member
Joined: 4 years ago

Hi Chris,

 

Here it is, thanks.

4 Replies
Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@highisland,

I see that the Adventurer usergroup is allowed to be set as secondary usergroup, so make sure that the Adventurer usergroup is not set for secondary usergroup, for those users who can't see the members list.

I just registered in your Website and got Customer Usergroup, and I can't see the Members List.

Change m account wpForoSupport to Adventurer Usergroup, but as primary, not as Secondary.

(@highisland)
Joined: 4 years ago

Eminent Member
Posts: 23

@chris I updated your usergroup to Adventurer

Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@highisland,

My Primary Usergroup is Adventurer and I can see the Members List.

(@highisland)
Joined: 4 years ago

Eminent Member
Posts: 23

@chris I had to change the role on the wpForo profile page and now it works.  I could have sworn my test user was adventurer already.  Anyway, thank you so much for looking into this.