Notifications
Clear all

wpForo 1.x.x [Solved] Fatal Error if I use old addons with wpForo v2

18 Posts
7 Users
0 Likes
483 Views
highme
Posts: 4
Topic starter
(@highme)
New Member
Joined: 9 months ago

Greetings,

Forum has been rolling along unencumbered for a while now. Yesterday I started getting messages from users that things were down. When I got a chance to look at it today I got this error message. Any advice as to how to restore it would be great, thanks

 

Fatal error: Uncaught TypeError: fclose(): Argument #1 ($stream) must be of type resource, bool given in /home/ezl_admin/ezloungin.com/wp-content/plugins/wpforo/wpf-includes/functions.php:843 Stack trace: #0 /home/ezl_admin/ezloungin.com/wp-content/plugins/wpforo/wpf-includes/functions.php(843): fclose(false) #1 /home/ezl_admin/ezloungin.com/wp-content/plugins/wpforo/wpf-includes/class-cache.php(152): wpforo_write_file('/home/ezl_admin...', 'a:23:{s:7:"foru...') #2 /home/ezl_admin/ezloungin.com/wp-content/plugins/wpforo/wpf-includes/class-cache.php(141): wpForoCache->create_files(Array, 'item', 'forum/') #3 /home/ezl_admin/ezloungin.com/wp-content/plugins/wpforo/wpf-includes/functions-template.php(1335): wpForoCache->create('item', Array, 'forum') #4 /home/ezl_admin/ezloungin.com/wp-content/plugins/wpforo/wpf-includes/class-posts.php(1313): wpforo_forum('4', 'slug') #5 /home/ezl_admin/ezloungin.com/wp-content/plugins/wpforo/wpforo.php(675): wpForoPost->get_post_url('54345') #6 /home/ezl_admin/ezloungin.com/wp-content/plugins/wpforo/wpf-includes/functions.php(1317): wpForo->statistic('update', 'all') #7 /home/ezl_admin/ezloungin.com/wp-content/plugins/wpforo/wpf-includes/functions-installation.php(97): wpforo_clean_cache() #8 /home/ezl_admin/ezloungin.com/wp-content/plugins/wpforo/wpf-includes/functions-installation.php(17): wpforo_activation() #9 /home/ezl_admin/ezloungin.com/wp-includes/class-wp-hook.php(307): do_wpforo_activation('') #10 /home/ezl_admin/ezloungin.com/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters('', Array) #11 /home/ezl_admin/ezloungin.com/wp-includes/plugin.php(474): WP_Hook->do_action(Array) #12 /home/ezl_admin/ezloungin.com/wp-admin/plugins.php(194): do_action('activate_wpforo...') #13 {main} thrown in /home/ezl_admin/ezloungin.com/wp-content/plugins/wpforo/wpf-includes/functions.php on line 843

wpForo Version
1.9.9.1
WordPress Version
5.9.2
17 Replies
Chris
Posts: 2385
Admin
(@chris)
Support Team
Joined: 1 year ago

Hi @highme,

We know about this issue, it has been fixed for wpForo major 2.0 version, and if this issue doesn't harm on the functionality of wpForo you can leave it. 

If you get problems from this issue, we can fix it on your website. Just let us know.

10 Replies
highme
(@highme)
Joined: 9 months ago

New Member
Posts: 4

@chris Appreciate the response but unsure on your instructions. Are you saying it's been fixed  wpForo 2.0 and I should upgrade to that?

 

I don't see anyway to upgrade to 2.0 at this point, so if there's something else I can do to fix it in the meantime that'd be great. I don't really like wpForo at all, but there's a few years of discussions in the database so instead of just nuking it I'd like to get wpForo back up and working. 

Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2385

@highme,

wpForo 2.0 version is not finished yet, but that issue has been fixed in it.

highme
(@highme)
Joined: 9 months ago

New Member
Posts: 4

@chris then how do I fix my site now? Should I just nuke my wpForo install and switch forum software? "Upgrading to a unavailable version" is not helpful.

Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2385

@highme,

if you get problems from the issue you mentioned above, we can fix it on your website.

If your website works and you don't have any problems from the issue you mentioned above, you can leave it for now, until we release wpForo 2.0 major version, where that issue is fixed.(wpForo 2.0 version is not released yet as it is not finished)

highme
(@highme)
Joined: 9 months ago

New Member
Posts: 4

@chris

I'm confused. Do you think I posted this because my website is working? It's been a week since I opened this thread and you just keep repeating yourself. I understand that it's been fixed in the not yet available 2.0. but that's the only information you've provided me. That's it. Nothing of use or value, just broken record shit. 

Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2385

@highme,

send admin credentials to info[at]gvectors.com, mention this topic in the email and let me know here that you have sent the email.

Octa-design
(@octa-design)
Joined: 4 months ago

New Member
Posts: 1
embark2
(@embark2)
Joined: 4 months ago

New Member
Posts: 2

@chris Hi. I have updated wpForo to 2.0 and it has issues with the Private Message plugin. I have rolled it back for now but any help will be good. Happy to start a new feed if you wish.

Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@embark2 ,

Please note that you cannot use wpForo v2 with old version of addons. The new versions are being released at the moment. Please read the update instruction before updating the plugin: https://wpforo.com/docs/wpforo-v2/getting-started/update-to-wpforo-v2/#3-updating-addons

embark2
(@embark2)
Joined: 4 months ago

New Member
Posts: 2

@robert Thank you for this. I will look to purchase the newer one as I don't know who has the original licence. I have inherited the maintenance of the site on behalf of the customer. Thank you for the document too. Jon

CENTRAL4ALL
Posts: 498
(@central4allgmail-com)
Prominent Member
Joined: 4 years ago

i update automaticaly all addons and now i get critical errors

Error Details
=============
An error of type E_ERROR was caused in line 7 of the file /home/admin/domains/http://adultforum.gr/public_html/wp-content/plugins/go2wpforo/includes/functions.php&source=gmail&ust=1659633519699000&usg=AOvVaw27wM5Pj8RTJHQxwSGfaqq C">adultforum.gr/public_html/wp-content/plugins/go2wpforo/includes/functions.php. Error message: Uncaught Error: Call to undefined function wpforo_is_admin() in /home/admin/domains/http://adultforum.gr/public_html/wp-content/plugins/go2wpforo/includes/functions.php:7&source=gmail&ust=1659633519699000&usg=AOvVaw18FRRBTRCIUF78S6xWHFO u">adultforum.gr/public_html/wp-content/plugins/go2wpforo/includes/functions.php:7
Stack trace:
#0 /home/admin/domains/http://adultforum.gr/public_html/wp-includes/class-wp-hook.php(307)&source=gmail&ust=1659633519699000&usg=AOvVaw3ieIohRGey3By509pP6Pf r">adultforum.gr/public_html/wp-includes/class-wp-hook.php(307): mg2wpforo_init()
#1 /home/admin/domains/http://adultforum.gr/public_html/wp-includes/class-wp-hook.php(331)&source=gmail&ust=1659633519699000&usg=AOvVaw0k5l-cZfJ1up1wsGL5yv- F">adultforum.gr/public_html/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters()
#2 /home/admin/domains/http://adultforum.gr/public_html/wp-includes/plugin.php(476)&source=gmail&ust=1659633519699000&usg=AOvVaw1LLLtAC0XdFse70bdjDlG L">adultforum.gr/public_html/wp-includes/plugin.php(476): WP_Hook->do_action()
#3 /home/admin/domains/http://adultforum.gr/public_html/wp-settings.php(461)&source=gmail&ust=1659633519699000&usg=AOvVaw0q2RZjaKBuEQ3Y2bHUz8r 3">adultforum.gr/public_html/wp-settings.php(461): do_action()
#4 /home/admin/domains/http://adultforum.gr/public_html/wp-config.php(85)&source=gmail&ust=1659633519699000&usg=AOvVaw0TiJEVvx3HETGJVKPX-ly y">adultforum.gr/public_html/wp-config.php(85): require_once('...')
#5 /home/admin/domains/http://adultforum.gr/public_html/wp-load.php(50)&source=gmail&ust=1659633519699000&usg=AOvVaw3HfOSqX_vdcBPC95LK5bc a">adultforum.gr/public_html/wp-load.php(50): require_once('...')
#6 /home/admin/domains/http://adultforum.gr/public_html/wp-admin/admin.php(34)&source=gmail&ust=1659633519699000&usg=AOvVaw0dLM0XTAiTJV15rpdK3iP f">adultforum.gr/public_html/wp-admin/admin.php(34): require_once('...')
#7 /home/admin/domains/http://adultforum.gr/public_html/wp-admin/edit-comments.php(10)&source=gmail&ust=1659633519699000&usg=AOvVaw0P06XJQJi2QuOMTAP9F4m _">adultforum.gr/public_html/wp-admin/edit-comments.php(10): require_once('...')
#8 {main}
  thrown

 
i renamed wpforo so the rest of the site to be online,
what should i do ?
 
Robert
Posts: 9912
Admin
(@robert)
Support Team
Joined: 7 years ago

Hmm, I don't see why you still keep active the OLD Go2wpForo tool??

All errors come from the old Go2wpForo tool, it cannot be automatically updated.

3 Replies
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

Please deactivate and delete the Go2wpForo tool, it's only necessary for forum migration, it's not an addon.

Oneil33
(@oneil33)
Joined: 2 years ago

Eminent Member
Posts: 19

@robert I can’t access my admin panel it saying critical error please help

Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@oneil33 ,

You should delete wpForo plugin from  /wp-content/plugins/ folder.  Please  read  my answer here: https://wpforo.com/community/postid/67850/

Oneil33
Posts: 19
(@oneil33)
Eminent Member
Joined: 2 years ago

I got access back to my site now, I will follow the step you recommend now