Notifications
Clear all

wpForo 1.x.x Forum Loading A Brand New Page

3 Posts
2 Users
0 Likes
660 Views
jcardona
Posts: 14
Topic starter
(@jcardona)
Active Member
Joined: 3 years ago

I don't know if this will make sense but I'm building individual pages for our different communities. Each community has a corresponding forum. The pages will have links and other info at the top. Also, some of these communities are private. I'm using the shortcodes to insert the forums into each individual page. The problem is that when a user clicks on a topic (or any link really) on the forum, they're taken to the forum page-- so all the info and links are gone.

Is there a way to have the forum load topics within the page? Or at a breadcrumb to the original source? I just want the user to be able to get back to the specific community page once they're done with the forum.

2 Replies
CrisW
Posts: 281
(@crisw)
Reputable Member
Joined: 4 years ago
Posted by: jcardona

I don't know if this will make sense but I'm building individual pages for our different communities. Each community has a corresponding forum. The pages will have links and other info at the top. Also, some of these communities are private. I'm using the shortcodes to insert the forums into each individual page. The problem is that when a user clicks on a topic (or any link really) on the forum, they're taken to the forum page-- so all the info and links are gone.

Is there a way to have the forum load topics within the page? Or at a breadcrumb to the original source? I just want the user to be able to get back to the specific community page once they're done with the forum.

 

Hi @jcardona

The steps I typed up here in this article 
https://wpforo.com/community/how-to-and-troubleshooting-2/sub-categories/#post-23368

And here in this article 
https://wpforo.com/community/how-to-and-troubleshooting-2/add-menu-links-to-each-forum-in-forum-menu-bar/#post-23854

might apply to your situation.  You can try it. 

 

The problem is that when a user clicks on a topic (or any link really) on the forum, they're taken to the forum page-- so all the info and links are gone.

You can check each link "URL" and "Link Text" to see the actual codes there, (using the "Insert Edit Link" Icon) for example, it might have the direct link to your forum, like " / community / " when it should have been / community / forum1/ topic 1" 

Good luck and God bless you!  🙂 

 

Reply
jcardona
Posts: 14
Topic starter
(@jcardona)
Active Member
Joined: 3 years ago

Hi Cris,

Thank you so much for your quick response. Unfortunately, I think I didn't do a good job at explaining my issue. I have a built a page here so that it's easier to see what my problem: https://jno.pyu.mybluehost.me/fake-community-homepage/

As you can see, I have created a special page that is dedicated to this particular forum. It has some introductory text, some links on the sidebar, and even a widget of the most recent posts on that particular forum. There are also other tabs that have other stuff like a document library. The problem is that when a user clicks on any of the forum links, they're taking completely outside of the page so they lose the tabs, links, etc. To some extent, that's fine. No ideal but fine. However, if the user starts replying to topics or doing other stuff in the forum, there's no easy way for them to navigate themselves back to the special page and that's a big issue for me. There will potentially be a bunch of forums, each with its own special page, so adding them to the menu is not feasible. Plus a lot of this forums/pages will also be private and have special access permissions.

If I could at least make the links for the forum on this page open in a new window/tab, that would be incredibly helpful as at least, the special page will remain open.

I hope this helps and thanks for your help!

Reply
Share: