Notifications
Clear all

wpForo 1.x.x [Solved] Forum logging in problem - no link to login?

4 Posts
2 Users
0 Likes
894 Views
easyacc
Posts: 13
Topic starter
(@easyacc)
Active Member
Joined: 4 years ago

When a guest comes to my front page of the forum there is no obvious link to login?

I've tried using the Tools/Miscellaneous to add link but whatever I put in there doesn't display unless I am actually logged in as a user?

I am trying to lock down the forums so only logged in users can see anything but can't seem to show login or registration links..

3 Replies
easyacc
Posts: 13
Topic starter
(@easyacc)
Active Member
Joined: 4 years ago

For registration I have disabled "Anyone can Register" within Wordpress Settings \ General Settings but not understanding the lack of login link?

Reply
easyacc
Posts: 13
Topic starter
(@easyacc)
Active Member
Joined: 4 years ago

Following the W3 Total Cache issue, I can now add a link to the login screen using the Tools\Misc\Admin Note so that is is sorted as well.

Reply
Robert
Posts: 9278
Admin
(@robert)
Support Team
Joined: 6 years ago

The login and register links are displayed on top menu bar.

Please don't use hard-codded links. They have url shortcodes in menus described in documentation here:

https://wpforo.com/docs/root/getting-started/forum-menu/

Also please exclude the forum page from W3 Total Cache plugin. wpForo has built-in cache you should not use W3 Total Cache on forum page. Here is an instruction to exclude some page form W3 Total Cache plugin: https://www.itsupportguides.com/knowledge-base/wordpress/w3-total-cache-how-to-exclude-posts-and-pages/

Reply
Share: