Clear all

wpForo 1.x.x [Solved] Forum page is empty for certain users

3 Posts
2 Users
Posts: 2
Topic starter
New Member
Joined: 3 years ago

I'm having this same issue. Here's what I've checked so far:

  1. I've verified that I'm running the latest version of wpForo (currently 1.9.7).
  2. This issue is affecting more than one user. Another admin reported it to me, and I've verified that it's affecting my account as well.
  3. I've checked all my forum settings to make sure that "Registered" group (synched with "Subscriber" on my site) has "Standard" access.
  4. I've verified that "Standard" still has the "Can create topic" permission (along with all the other default "Standard" permissions).
  5. I've verified that my forums have the forum permission for "Registered" set to "Standard access".
  6. I've refreshed my forum multiple times and tried in different browsers.
  7. I'm personally logged in as an "Admin" (and the forums are set for "Admin" to have "full access").
  8. I've followed the advice on wpForo Usergroups, Forum Accesses and WordPress User Roles.

Does anyone have any suggestions as to why the "Add topic" button isn't appearing anywhere? 

2 Replies
Posts: 10479
Support Team
Joined: 8 years ago


You've done incorrect configuration of your forums' permissions. All forums are not accessible for that users, so they don't see the [add topic] button. You should read the topic again and check all top level forum permissions.

If you want us to help you, please edit all top level forums (categories), take screenshots of permissions settings, then take screenshot of the user's usergroup and his/her forum accesses, so I can see what have you done wrongly.

BTW, the default permissions settings work fine, I have no idea why have you mess all up.

1 Reply
Joined: 3 years ago

New Member
Posts: 2

@Robert Thank you! That fixed it. I just needed to add forums to my categories. I had left all my categories (the blue panels) empty. Now that I've added forums underneath the categories, everything displays as I would expect it to. Thanks for the great help!