Notifications
Clear all

wpForo 1.x.x [Closed] Forum screen display not working

4 Posts
2 Users
0 Likes
1,173 Views
Posts: 3
Topic starter
(@toxicfox)
Active Member
Joined: 4 years ago

I have a problem with my forum where it doesnt fill the full width of the screen, ive got it selected to full width template. Have a look here https://bgnforums.com/forums/

3 Replies
Sofy
Posts: 4318
 Sofy
Admin
(@sofy)
Support Team
Joined: 6 years ago

Hi @toxicfox,

The issue comes from the active theme, it sets the following CSS rule: 

body.template-full-width .entry-content > *:not(.alignwide):not(.alignfull):not(.alignleft):not(.alignright):not(.is-style-wide), body.template-full-width [class*="__inner-container"] > *:not(.alignwide):not(.alignfull):not(.alignleft):not(.alignright):not(.is-style-wide) {
max-width: 120rem;
}

If you want to overwrite that rule use the CSS code below:

body.template-full-width .entry-content > *:not(.alignwide):not(.alignfull):not(.alignleft):not(.alignright):not(.is-style-wide) {
width: 100% !important;
max-width: 99%;
}

The CSS codes should be added in the "Custom CSS code" textarea, located in the Dashboard > Forums > Settings > Style Tab.  

The red marked codes can be changed as you like. 

Please don't forget to delete all caches and press Ctrl+F5 (twice) on the frontend before checking to reload the updated CSS file.

Posts: 3
Topic starter
(@toxicfox)
Active Member
Joined: 4 years ago

ahh thank you, but how do i get rid of the normal background theme, so the forum can sorta be its on page if u know what i mean

1 Reply
Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4318

@toxicfox

 

The CSS codes should be added in the "Custom CSS code" textarea, located in the Dashboard > Forums > Settings > Style Tab.

Please note, all questions related to your active theme should be asked in the theme's support forum, not here.