Notifications
Clear all

wpForo 1.x.x Forum SEO

11 Posts
6 Users
0 Likes
4,719 Views
Posts: 7
Topic starter
(@mikeg)
Active Member
Joined: 6 years ago

What type of built in SEO does the forum have? I tried to copy and paste the link to the post in my forum onto google and it doesn't show up at all which means that you can not find any post in my forum from Google. How do I fix this? I am running a website that deals with aquarium pets. I want someone who is searching for something like water changes or care for a specific animal that someone created a post for to be easily accessible on Google.

10 Replies
Robert
Posts: 9966
Admin
(@robert)
Support Team
Joined: 7 years ago

Hi mikeg,

It seems you have conflict with other SEO plugins. please make sure forums and topics has according meta title and description.

wpForo SEO based on main SEO components:

  • SEO Friendly URLs
  • Meta Title for forums and topics (and other pages)
  • Auto-generated Meta Description for forums and topics (and other pages)
  • Open Graph and Social Engine SEO tags.
  • Well formatted and SEO friendly content structure.

You can check it for wpforo.com. It's being indexed very well, you can see new topics and posts in Google result after 1-2 hours (use time tool in search result).

More info about wpForo SEO:

https://wpforo.com/docs/root/wpforo-settings/general-settings/#forum-title-desc

BTW: please leave your forum URL, we'll check and let you know if wpForo SEO works or not.

 

Reply
1 Reply
(@mikeg)
Joined: 6 years ago

Active Member
Posts: 7
Robert
Posts: 9966
Admin
(@robert)
Support Team
Joined: 7 years ago

That because you use All In One SEO pack plugin, this plugin removes wpForo forum/topic SEO titles. You should change it to Yoast SEO or wait for future wpForo versions. We work on this to make wpForo SEO compatible with All in One SEO Pack.

Reply
Posts: 316
(@1sharonkat)
Reputable Member
Joined: 6 years ago

That because you use All In One SEO pack plugin, this plugin removes wpForo forum/topic SEO titles.

I'm also using All in One SEO and I do not see on my site that issue unless if I'm missing something. In other word either I did not understand the question or the answer.
My forum:
http://www.mityaalim.org/community/

From my experience with SEO, it takes more then 2 months to show-up in the search engines. 

Thank you

Reply
Robert
Posts: 9966
Admin
(@robert)
Support Team
Joined: 7 years ago

It may not conflict, its not mandatory. The time of index depends on website rank and language. On wpForo.com new topics become available in google.com within 24 hours. Here we use the same plugin without with default configurations, nothing special and extra.

Reply
1 Reply
(@mikeg)
Joined: 6 years ago

Active Member
Posts: 7

So if i disable my All In One SEO plug in and only use Yoast SEO It should fix the problem? 

According to my host it says my ranking on Google is page 1 site 4. If you search "Axolotl City" the information is currently accurate. 

Reply
Page 1 / 2