Notifications
Clear all

wpForo 1.x.x [Solved] Forum Styling Issue Navigation Dropdown

5 Posts
2 Users
0 Likes
1,328 Views
NSH
Posts: 94
 NSH
Topic starter
(@studio500)
Estimable Member
Joined: 5 years ago

Hello, I seem to have developed a strange styling issue with the  Navi dropdown (I think) over stretching the page and encroaching onto my sidebar. See Image

I see that the size is set to auto already. Is there a way to fix this with css please?

In firebug I do see an alert for an invalid property name, next to appearance: none; below.

The page with the errors is https://www.bisfhouse.com/Community/main-forum/

#wpforo #wpforo-wrap .wpf-navi select.wpf-navi-dropdown {
appearance: none;
width: auto;
-webkit-appearance: none;
-moz-appearance: none;
font-size: 12px;
padding: 1px 10px !important;
margin: 0 1px 0 2px;
cursor: pointer;
}

Is there a way to fix this with css?

Many thanks

Topic Tags
4 Replies
4 Replies
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

That page is not available. We can't check it.

NSH
 NSH
(@studio500)
Joined: 5 years ago

Estimable Member
Posts: 94

Sorry, it should be accsible now. 😀 

Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

This problem comes from your theme style.css, it sets min-width:100% to all dropdowns. Put this CSS code in Dashboard > Forums > Settings > Styles > Custom CSS code textarea to overwrite it. Save it, delete all cache, navigate to forum front-end and press Ctrl+F5 to reset browser cache:

#wpforo #wpforo-wrap .wpf-navi select.wpf-navi-dropdown {
     min-width: auto;
}
NSH
 NSH
(@studio500)
Joined: 5 years ago

Estimable Member
Posts: 94

Thank you Robert, works a treat.

I'll get in touch with theme developers to ak them why the theme has been set up like this. 👍