Notifications
Clear all

wpForo 1.x.x [Closed] Have to approve posts at least twice

4 Posts
3 Users
0 Reactions
1,476 Views
Wendell
Posts: 242
Topic starter
(@wendell)
Reputable Member
Joined: 7 years ago

A recent phenomenon I've noticed has to do with approving posts. I have my site setup to require approval of the first two posts for users that are suspected as possible spammers. When a new user posts a new topic, I get a notification to moderate that post -- so I approve it and people start replying to that post. Then the OP returns and replies to that topic and now both the new post and the original topic post require approval. So, in other words, the new user starts a new topic and people participate -- then when he replies, the whole thread disappears for all users until I re-approve the original post and the new reply.

I'm not sure if this is a bug or a problem specific to my website ( https://rplstoday.com).

3 Replies
Sofy
Posts: 4495
 Sofy
Admin
(@sofy)
Support Team
Joined: 6 years ago

HiΒ Wendell,

We'll check it and back to you asap.Β 

Wendell
Posts: 242
Topic starter
(@wendell)
Reputable Member
Joined: 7 years ago

Thanks Sofy.

I should also mention that when the older posts go back into moderation, I do not receive an email notification for those (only the new ones), so they can sometimes go for a couple of days before I notice them.

Robert
Posts: 10527
Admin
(@robert)
Support Team
Joined: 8 years ago

Yes, this is designed that way.Β  You can find all unapproved topics and posts in Dashboard > Forums > Moderation admin page. We will work on antispam system to make it more gentle. At the moment if a user is new user and if some post of this user become unapproved the antispam system makes all previous posts unapproved too. We will add an option to pass approval if a user already has an approved topic/post.