Notifications
Clear all

wpForo 1.x.x [Solved] How to avoid random page URL defaulting to Forum login page?

29 Posts
5 Users
1 Reactions
2,874 Views
Posts: 86
Topic starter
(@janjan)
Estimable Member
Joined: 6 years ago

Hi,

The page  https://authentic-self-empowerment.com/ase-supervision-group-session-videos/ is a page that for privacy reasons requires a password to access a series of training videos on the next page, but instead of displaying the password box (as visible in the screenshot attached), the viewer gets redirected to the forum login page ( https://authentic-self-empowerment.com/ase-supervision-group-forum/?foro=signin), which is not intended.

Only when logged into Wordpress as an admin does the page open without a redirection to the forum login page.

Which setting do I have to change in order to have the page being displayed and not the forum login?

Please let me know if furher explanation is required. Thank you.

28 Replies
Sofy
Posts: 4562
 Sofy
Admin
(@sofy)
Support Team
Joined: 6 years ago

@janjan,

Could you please send the admin login details to info[at]gvectors.com email address? I'll ask the developers to check this for you. 

Posts: 86
Topic starter
(@janjan)
Estimable Member
Joined: 6 years ago

Done, thank you Sofy.

Posts: 86
Topic starter
(@janjan)
Estimable Member
Joined: 6 years ago

Sofy, did the developers get back to you? Several customers have complained because they are being redirected. Do you have an update for me? Thank you.

1 Reply
Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4562

@janjan,

Not yet. I'll contact them and let you know. 

Alvina
Posts: 1867
Moderator
(@alvina)
Member
Joined: 5 years ago

Hi @janjan,

You created a post, set it password-protected, and in this post content, you are using the [wpforo item="forum" id="2"] shortcode. On the page that has the 2 ID, the guest does not have permission to see the forum (can view topic is disabled for guests). Thus wpForo doesn't recognize this page via 2 ID, and it redirected to the login page.
To solve it you just need to not use the shortcode for that post, because of the content on that post is videos and texts, and it more like a blog than a forum page. Instead of the shortcode you just need to use the URL to go to the forum page, then let users know to go to the forum ad use it.
After going to the forum page, if the "can view topic" permission doesn't exist, then you just need to redirect the user to the login page to authorized and start using the forum.

Page 1 / 4