Notifications
Clear all

wpForo 1.x.x How to noindex rss

5 Posts
2 Users
0 Likes
628 Views
shpargalkaforum
Posts: 7
Topic starter
(@shpargalkaforum)
Active Member
Joined: 2 years ago

Hello dears. I was asking on Russian support forum how I can hide from search engine rss pages wpforo. But guys tell me ask you on this is forum, create noindex for rss pages.

Forum generate to much rss urls also this all indexed google and Yandex. For example:  https://www.russpuss.ru/?id=9701575224?type%3Drss2&forum=g?type=rss2&forum=g

 

Thanks

Topic Tags
4 Replies
Robert
Posts: 9262
Admin
(@robert)
Support Team
Joined: 6 years ago

Hi @shpargalkaforum,

I have no idea why your RSS URLs contains this part /?id=9701575224 ?

What is that? This is an injection from other plugins, which makes RSS URLs duplication like your example:

 https://www.russpuss.ru  / ?id=9701575224?type%3Drss2&forum=g?type=rss2&forum=g

Do you see the duplication parts? This is the reason of incorrect indexing and Google errors. There is no such problem in wpForo for sure. This is an affection by other plugins or JS codes.

If you can find the plugin which adds this extra URL part to the RSS URL it'll be better than disabling RSS indexing.

Currently, wpForo doesn't have an option to stop RSS indexing. We'll add it in the upcoming version.

 

Reply
shpargalkaforum
Posts: 7
Topic starter
(@shpargalkaforum)
Active Member
Joined: 2 years ago
Reply
shpargalkaforum
Posts: 7
Topic starter
(@shpargalkaforum)
Active Member
Joined: 2 years ago
Reply
1 Reply
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9262

@shpargalkaforum,

Ok, this is cased on topics with pagination as well. I've added this to our bug-fix list. But the ?id=9701575224 related issue is out of our support.

In any case we'll add a hook or an option to set nofollow all RSS links in upcoming version. 

Reply
Share: