Notifications
Clear all

wpForo 1.x.x [Solved] How to set forum up so it doesn't require login for read only.

20 Posts
4 Users
0 Likes
795 Views
redrover61
Posts: 17
Topic starter
(@redrover61)
Active Member
Joined: 11 months ago

Hi, I would like to have visitors to my site to be able to read topics and posts on a read-only level and once registered able to add topics, add media to posts etc.. That is not how my forum is working. It is requiring everyone to register in order to read anything. The user group settings are here: https://prnt.sc/kSoaqXa1Nobe and the user roles are as follows: https://prnt.sc/BgqGDW2_Du4F . Pretty much everything is setup as default including forum accesses. Am I missing a big part of the picture? If anyone can point me in the right direction I'd appreciate it.

19 Replies
Robert
Posts: 9912
Admin
(@robert)
Support Team
Joined: 7 years ago

Hi @redrover61,

wpForo does all you want by default. Why have you  changed the forum accesses?

By default, wpForo shows all forums and let guests to read topics. If some users want to create a topic or reply, he/she will be asked to register or login. This is the default behavior of wpForo.

Now, I see you've made lots of changes in forum accesses, and you try to fix your issue in usergroup settings. You should edit each category and forum one by one and set "Read Only" access to Guest usergroup.

Then you should edit the Read Only forum access in Forums > Settings > Forum Accesses admin page and make sure it's configured like this:

 

You have nothing to do with Usergrous, so please don't mention them.

Reply
redrover61
Posts: 17
Topic starter
(@redrover61)
Active Member
Joined: 11 months ago

Hi, thanks for the reply. As I mentioned in my post the forum accesses are default as seen here: https://prnt.sc/BgqGDW2_Du4F . 

Posted by: @robert

You should edit each category and forum one by one and set "Read Only" access to Guest usergroup.

If you are referring to this : https://prnt.sc/D5CAlsZxE3_Z , they are set as seen. I've never changed any of them from default.

Reply
1 Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@redrover61,

I see you have set no access to forums. I cannot see forums as guests. So you have made some changes in accesses. If the parent category is set "not access" to guests, then all forums of that categories will not be displayed.

So you should find the incorrect things your salve, I don't know what have you done with your permissions. If you want me to help, you should provide screenshot of each category edit screen and screenshot of all forum accesses in Forum > Settings > Forum Accesses admin page.

IMPORTANT!

Make sure you have forums under the categories. If you have only created categories, you'll not see them on the forum front. All categories must have at least one forum.

Reply
redrover61
Posts: 17
Topic starter
(@redrover61)
Active Member
Joined: 11 months ago
Posted by: @robert

you should provide screenshot of each category edit screen

I've already checked these as stated but here they are: https://prnt.sc/4_W71mf6qBlt , https://prnt.sc/UhgKvrKUYTZy , https://prnt.sc/f9wmSfFr30tI , https://prnt.sc/f4CN_RZrO24H , https://prnt.sc/8I98rCvf5eUY .

Posted by: @robert

and screenshot of all forum accesses in Forum > Settings > Forum Accesses admin page

Here are the accesses edit screens (I've already sent the read only screenshot in my last post): https://prnt.sc/jH696JdpU1rR , https://prnt.sc/c9MB_kjLuGNM , https://prnt.sc/zP2BNShTsf0l , https://prnt.sc/i8Bono8FOuJ6

 

I've not changed any of these settings, no need to. All I've done was create the categories and forums, changed the color scheme to match my site and changed the topics to be extended so they are always visible, I think that is it. I've finally got around to checking everything on my site as a visitor and I came across this. I didn't figure this was going to be an easy issue as I have searched Google for many hours and found nothing on this issue and that's why I posted here.

Reply
1 Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@redrover61,

Thank yo for the screenshots. All is ok, but something very strange is going on.

1. If you have any kind of caches, please purge them and remove the forum page from your cache plugins:

2. Make sure you don't have a server side cache, if there is one, just purge that cache as well.

3. Then try to disable other plugins and check it. This could also be a plugin conflict.

4. Go to Dashboard > Forums > Tools > Debug Tab > Tables sub-tab and make sure there is no any issues with database.

5. Go to Dashboard > Forums > Tools > Debug Tab >Errors & Issues and make sure there is no any errors in your WordPress website.

6. Deactivate wpForo (do not use the Uninstall button) and activate it.

Reply
Tutrix
Posts: 827
(@tutrix)
Noble Member
Joined: 3 years ago

you have "2" community (forum) sides, one aligned left one aligned right

https://www.screencast.com/t/8iNT0v1J

https://dot.photos/community/
https://dot.photos/community-2/

you use additionally

BuddyPress + Youzify

maybe you have a setting that requires a login to be able to read the forum as a guest

Reply
Page 1 / 3