Notifications
Clear all

wpForo 1.x.x [Solved] How to set forum up so it doesn't require login for read only.

20 Posts
4 Users
0 Likes
888 Views
Posts: 17
Topic starter
(@redrover61)
Active Member
Joined: 1 year ago

@robert Thanks for the suggestions, the results are as follows:

Posted by: @robert

5. Go to Dashboard > Forums > Tools > Debug Tab >Errors & Issues and make sure there is no any errors in your WordPress website.

There was a message in "errors & issues" saying "The default Guest usergroup is not found!"

"Please execute this SQL in your Website Hosting cPanel > phpMyAdmin Database Manager:"

Then it listed all the data for that database entry.See here: https://prnt.sc/3mUScf5558-w

There was a guest usergroup in the database but it had the usergroup id as 7 so I changed it to 4 as it stated in the code. The error disappeared but it still didn't work. So I looked at the usergroup page and the User Role for guest was missing some fields, see here: https://prnt.sc/iUF_NHDA4cn3 kind of like WPForo didn't recognize id 4 at all, but the error is gone so I don't know.

I change it back to id 7 and the field data returns but I again get the error. I can toggle the usergroup id back and forth in the database and get the same results every time. I did this throughout all my testing, because I didn't know for sure which was the better of the two options.

 

Posted by: @robert

1. If you have any kind of caches, please purge them and remove the forum page from your cache plugins:

2. Make sure you don't have a server side cache, if there is one, just purge that cache as well.

I'm not using any cache plugins and all cache is disabled on my server.

 

Posted by: @robert

3. Then try to disable other plugins and check it. This could also be a plugin conflict.

I've disabled all plugins except wpforo and had the same results, I left all plugins disabled throughout my testing just to be sure.

 

Posted by: @robert

4. Go to Dashboard > Forums > Tools > Debug Tab > Tables sub-tab and make sure there is no any issues with database.

 No Problems Found in Database

Posted by: @robert

6. Deactivate wpForo (do not use the Uninstall button) and activate it.

Did this throughout troubleshooting as well, nothing changed.

 

So that's where it stands now. I don't know which usergroup id is correct, is there a way to set that id? Or is it set by doing what I did by changing it in the database? Somehow, somewhere I believe some data got corrupted. Maybe something else is still corrupted. I think when I first built the forums the group id started out to be 7 because if you look at the database https://prnt.sc/j_4uRcd6lpaG every group id would be an odd number and it makes sense. But now some part of WPForo thinks it should be 4 because that is what it is saying to set it to in that error message.

If I delete and re-install WPForo do you think this will be set right? I know with most plugins you delete the plugin but the data remains intact.

Or maybe you know of this issue? I'm open for anything at this point.

 

Posted by: @tutrix

you have "2" community (forum) sides, one aligned left one aligned right

Yes, I know about the 2 community pages, I don't know what you mean by aligned left and right however. I tried deleting one of them but it errors out when I try to trash it. So I just set it to draft.

Posted by: @tutrix

you use additionally

BuddyPress + Youzify

maybe you have a setting that requires a login to be able to read the forum as a guest

I've disabled all the plugins during testing. Thanks for the suggestions.

 

Reply
Robert
Posts: 9966
Admin
(@robert)
Support Team
Joined: 7 years ago
Posted by: @redrover61

There was a message in "errors & issues" saying "The default Guest usergroup is not found!"

"Please execute this SQL in your Website Hosting cPanel > phpMyAdmin Database Manager:"

Then it listed all the data for that database entry.See here: https://prnt.sc/3mUScf5558-w

There was a guest usergroup in the database but it had the usergroup id as 7 so I changed it to 4 as it stated in the code. The error disappeared but it still didn't work. So I looked at the usergroup page and the User Role for guest was missing some fields, see here: https://prnt.sc/iUF_NHDA4cn3 kind of like WPForo didn't recognize id 4 at all, but the error is gone so I don't know.

What???

Why the usergroup 4 was deleted???

wpForo doesn't allow deleting the Guest usergroup with ID: 4, how and why have you deleted it?

Now your forum doesn't have any chance to work correctly.

Ok, now you should execute the SQL again. There MUST be usergroup with 4 ID for guest. Delete the current ID 7 guest. Delete and remove it from all places. Just remove it asap!!!

The guest usergroup MUST have ID: 4. Once it's created, go to Dashboard > Forums > Dashboard and delete all caches, delete user caches.

THEN, edit each forum one by one and set Read Only forum access to the new guest usergroup.

Go to Dashboard > Forums > Dashboard and delete all caches, delete user caches.

 

You should NEVER change the ID or delete the Guest Usergroup.

Reply
Posts: 17
Topic starter
(@redrover61)
Active Member
Joined: 1 year ago
Posted by: @robert

Why the usergroup 4 was deleted???

wpForo doesn't allow deleting the Guest usergroup with ID: 4, how and why have you deleted it?

At no point did I say I deleted usergroup 4. Like you said wpForo does not allow it. There is no delete option available for it. I merely changed the group id in the database to 4 as per the error code it was giving. Then since that didn't work either I changed it back to 7. I sent screenshots of everything I did.

d

Posted by: @robert

Ok, now you should execute the SQL again. There MUST be usergroup with 4 ID for guest. Delete the current ID 7 guest. Delete and remove it from all places. Just remove it asap!!!

The usergroup 7 did have an option to delete and I have deleted it. The database table is as such: https://prnt.sc/XI4c7MsqsM7s , as I mentioned in my last the error message has cleared: https://prnt.sc/LUmvScpq9Yyi , however the User role, members and default fields are blank as I mentioned before: https://prnt.sc/CigbWSozVgXod

Posted by: @robert

The guest usergroup MUST have ID: 4. Once it's created, go to Dashboard > Forums > Dashboard and delete all caches, delete user caches.

I have deleted the 'all cache' and 'user cache'. No change.

 

Posted by: @robert

You should NEVER change the ID or delete the Guest Usergroup.

I don't think it's possible to change the ID's or to delete the Guest Username. There's some other explanation as to how this got to be the way it is.

I think it may be from installing Minerva Knowledge Base. After that was installed I noticed it created 3 new User Roles 'Minerva Support User', 'Minerva Support Agent' and 'Minerva Support Manager' and it assigned itself to guest and moderator. I don't know why or how they got added to wpForo.

 

I don't have anything important in this forum and I can re-create what I have pretty quickly so I can delete and start over but I don't know what all I have to delete.

 

Reply
Robert
Posts: 9966
Admin
(@robert)
Support Team
Joined: 7 years ago
Posted by: @redrover61

The database table is as such: https://prnt.sc/XI4c7MsqsM7s

This is wrong. The Guest Usergroup should look like this:

 

Then go to Dashboard > Forums > Usergroups, edit the new Guest usergroup and set all permissions like this:

 

Correct the role and visibility fields in the table, then delete wpForo caches in Dashboard > Forums > Dashboard admin page:

  • Delete Users Cache
  • Delete All Caches

 

Then edit each category and forum one by one, make sure the guest usergroup have read only access and save it. The guest is a new guest, so it should be saved for each forum again.

Just do all these and the all issues should be fixed.

 

Reply
Posts: 17
Topic starter
(@redrover61)
Active Member
Joined: 1 year ago

Hi, and thanks for the suggestions.

I have edited the database table as suggested so it now looks like so: https://prnt.sc/ZIzgjM9-8pLP and verified all categories and forums have guest as read-only, I have verified permissions are as such: https://prnt.sc/Z8Fku4j1olPA. I deleted all and user cache.

But the usergroups still look like this: https://prnt.sc/kpOSVb0vSY2T and user role is still not indicating subscriber as guest as seen here: https://prnt.sc/GoIyVVPYuVdk

But guess what, I can now see the forum on the front end as a guest. https://dot.photos/community-2/

So it's still messed up a bit on the backend but much better.

Reply
1 Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9966

@redrover61,

All is correct now. The guest usergroup is not a regular usergroup, it's for not loggedin visitors, it cannot be connected to subscriber user role.

Reply
Page 2 / 3