Notifications
Clear all

wpForo 1.x.x [Closed] I get this message: "Error 2253 | Please contact to forum admin." after adding topics or replies

6 Posts
2 Users
0 Reactions
4,767 Views
Posts: 6
Topic starter
(@tomschoute)
Active Member
Joined: 7 years ago

Hi,

I've just installed WPForo on my test side. As manager I could add categories and forums. All seem to work well but when I wanted to test adding a topic as a regular registered user I got the above message after pressing the Submit button.

I've checked the database and all WPForo tables seem to be there.

Am I missing something?

Please help because I am evaluating WPForo amongst other forum plugins to use on our website and I am stuck now.

 

5 Replies
Robert
Posts: 10520
Admin
(@robert)
Support Team
Joined: 8 years ago

This may be WordPress Session issue.

Please make sure you're logged in when you test it.

Disable all plugins and test it again

If you can't find a solution please send admin login details to support[at]gvectors.com email address. We'll check it and find the problem causer.

Posts: 6
Topic starter
(@tomschoute)
Active Member
Joined: 7 years ago

I get this message as well if I use the built in login from WPForo (and then can't see any forum). I also get this message when I've disabled all other plugins.

If I use another login (My Theme Login) I see the forums and can read them etc. but get the error when submitting a topic or reply.

Should that work or should I try another login?

Robert
Posts: 10520
Admin
(@robert)
Support Team
Joined: 8 years ago

This error comes when the website URL doesn't match WordPress URL. When the referrer domain name doesn't mach to current page domain name. Could you please navigate to Dashboard > Settings > General and check if the both WP URLs are the same? Something wrong with your website URL and domain name structure. This is a security risk detection by wpForo and it doesn't allow any action.

1 Reply
(@tomschoute)
Joined: 7 years ago

Active Member
Posts: 6

They are both the same (tom.prolin.com). However, since this is a staging version of my life website the URL to use to get to this test site is different (staging2.tom.prolin.com).

The "staging2" part is put there automatically. 

Is this causing the problem? Is there another way I should use staging sites with the WPForo plugin?

Robert
Posts: 10520
Admin
(@robert)
Support Team
Joined: 8 years ago

Yes, that's the issue, both URLs should be staging2.tom.prolin.com or tom.prolin.com. They should not be different. Maybe you've forced URLs in wp-config.php. All issues come from this URL changes.