Notifications
Clear all

wpForo 1.x.x I have 7 Forums but Forums Page shows only three ?

11 Posts
2 Users
0 Likes
601 Views
Jatin
Posts: 23
Topic starter
(@jatin)
Eminent Member
Joined: 1 year ago

Hi Team,

First Question: I have created 7 Forums on my site but it shows only 3 Forums by default on my site. Is there any setting which i can change to show all the Forums when someone visits my Forum Page https://techpress.net/forums

Second Question: I have Google recaptcha enabled on my site by still getting SPAM accounts being created. How can i fix it. I do not have any third party recaptcha just using WPForo's -> Tools -> privacy tab there i have added google recaptcha.

Thank You.

10 Replies
Robert
Posts: 9912
Admin
(@robert)
Support Team
Joined: 7 years ago

Hi @jatin,

I see all your 7 forums with three categories.

Please make sure you've excluded the forum page from your cache plugin. wpForo forum page should not be cached by cache systems, here is the instruction: https://wpforo.com/community/faq/wpforo-and-cache-plugins/

Reply
Jatin
Posts: 23
Topic starter
(@jatin)
Eminent Member
Joined: 1 year ago

Thanks, Forum was empty so it was not showing it. I added topics to the Forum and its showing it now. 

What about the second query? Forum pages are excluded from cache from day 1.

Second Question: I have Google recaptcha enabled on my site by still getting SPAM accounts being created. How can i fix it. I do not have any third party recaptcha just using WPForo's -> Tools -> privacy tab there i have added google recaptcha.

Reply
3 Replies
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@jatin,

Nowadays, reCAPTCHA is not enough to protect a website against spam. There is no 100% protection, so people try different solutions and plugins. wpForo user registration is based on WordPress user registration system, so almost all WordPress spam protection solutions work for wpForo as well. Please read all points of this FAQ topic: https://wpforo.com/community/faq/how-to-stop-spam/

Reply
Jatin
(@jatin)
Joined: 1 year ago

Eminent Member
Posts: 23

@robert Thanks for the article, very useful.

I have an issue though which i want to highlight may be you already know and guide me here. I have enabled Google recaptcha v2 on my site via WPForo and it works fine when i use login button on WPForo Forum but when i use my site with /wp-admin the re-captcha fails and i get error message Google recaptcha verification failed.

There are no modifications on my site and Forum page is excluded from cache. Not sure why this will fail on wordpress login page which has /wp-admin.

 

 

 

Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@jatin,

Ok, we'll check it and update if necessary. At the moment, you can disable it for the /wp-admin/ path, and redirect all login attempts to wpForo login page by enabling these options in Forums > Settings > Features Tab:

  • Replace Registration Page URL to Forum Registration Page URL
  • Replace Login Page URL to Forum Login Page URL
  • Replace Reset Password Page URL to Forum Reset Password Page URL
Reply
Jatin
Posts: 23
Topic starter
(@jatin)
Eminent Member
Joined: 1 year ago
Posted by: @robert

 

  • Replace Registration Page URL to Forum Registration Page URL
  • Replace Login Page URL to Forum Login Page URL
  • Replace Reset Password Page URL to Forum Reset Password Page URL

 

Hi Robert,

Sounds good. But can you please advice me how to do these ?

I am happy to move / redirect from wp-admin to Wpforo login / registration pages. But not sure how to do it.

Reply
3 Replies
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@jatin,

You just need to set "Yes" the three options in Forums > Settings > Features Tab:

Reply
Jatin
(@jatin)
Joined: 1 year ago

Eminent Member
Posts: 23

@robert. thanks this works.

I have Four more queries. Hope thats ok ?

1. Google reCaptcha on your site or mine when recaptcha checkbox is clicked instead of showing pictures it simply shows a green tick. Is it normal.

2. I understand your WPForo Forum has moderation for each post enabled. But i have seen after 3-4 replies on your side my next reply wasn't put to moderation automatically. After coupld of approvals i believe it automatically starts trusting and does not put the next replies in moderation. Thats something i got to know from my replies on this post on your site.

3. How can i set a default avatar for any new user. I know most users will not upload the pictures so is there any way to se a default one to make user thumbnail picture look nice by default.

4. Forum Registration page shows below text. Is it possible to remove it ?

Join us today!

Reply
Jatin
(@jatin)
Joined: 1 year ago

Eminent Member
Posts: 23

Any Update ?

Reply
Robert
Posts: 9912
Admin
(@robert)
Support Team
Joined: 7 years ago
Posted by: @jatin

1. Google reCaptcha on your site or mine when recaptcha checkbox is clicked instead of showing pictures it simply shows a green tick. Is it normal.

Sometimes it shows image, sometimes it shows green tick. It depends on your IP address and your device. If Google suspects something, it shows images. Yes, this is the default Google reCAPTCHA behavior. It's different for each visitor.

 

Posted by: @jatin

2. I understand your WPForo Forum has moderation for each post enabled. But i have seen after 3-4 replies on your side my next reply wasn't put to moderation automatically. After coupld of approvals i believe it automatically starts trusting and does not put the next replies in moderation. Thats something i got to know from my replies on this post on your site.

We've not enabled moderation for each post. Here is our current settings:

 

Posted by: @jatin

3. How can i set a default avatar for any new user. I know most users will not upload the pictures so is there any way to se a default one to make user thumbnail picture look nice by default.

I'd recommend using Leira Letter Avatar plugin. We use it here at wpForo support forum.

 

Posted by: @jatin

4. Forum Registration page shows below text. Is it possible to remove it ?

You can change any phrase in wpForo front-end by editing the corresponding phrase in Dashboard > Forums > Phrases admin page.

Reply