Notifications
Clear all

wpForo 1.x.x Icons not showing when creating topic

5 Posts
3 Users
0 Likes
521 Views
Goodfella
Posts: 4
Topic starter
(@goodfella)
New Member
Joined: 11 months ago

Hello, on my forum all the icons seem to be working except the ones when I click on create topic or comment. It's supposed to be the icons where you can see Bold, Italic, Font size, etc. See the screenshot

[img] [/img]

4 Replies
Robert
Posts: 9912
Admin
(@robert)
Support Team
Joined: 7 years ago

@goodfella,

The "Great top" and "Reply" permissions are disabled, and we cannot see the editor to help you. We need to see the editor to inspect this problem. In most case this issue custom  from custom CSS which sets font for all elements. This is a font conflict. So just review all your custom CSS codes or let a new registered user to see the topic/post editor.

Reply
1 Reply
Goodfella
(@goodfella)
Joined: 11 months ago

New Member
Posts: 4

@robert I've made an account with the login name: Code and the pw: Test100
You can try and create a topic in the Test forum section so you can see the icons I'm missing. The only one that shows is the 11pt

Also my custom CSS is:
#wpforo #wpforo-wrap .fas{
font-family: "Font Awesome 5 Free" !important;
font-weight: 900 !important;
top: 0 !important;
}
#wpforo #wpforo-wrap .far{
font-family: "Font Awesome 5 Free" !important;
font-weight: 400 !important;
top: 0 !important;
}
#wpforo #wpforo-wrap .fab{
font-family: "Font Awesome 5 Brands" !important;
top: 0 !important;
}

Reply
Tutrix
Posts: 825
(@tutrix)
Noble Member
Joined: 3 years ago

@goodfella

add this to custom css

i.mce-i-aligncenter, i.mce-i-alignjustify, i.mce-i-alignleft, i.mce-i-alignright, i.mce-i-backcolor, i.mce-i-blockquote, i.mce-i-bold, i.mce-i-bullist, i.mce-i-charmap, i.mce-i-dashicon, i.mce-i-dfw, i.mce-i-forecolor, i.mce-i-fullscreen, i.mce-i-help, i.mce-i-hr, i.mce-i-indent, i.mce-i-italic, i.mce-i-link, i.mce-i-ltr, i.mce-i-numlist, i.mce-i-outdent, i.mce-i-pastetext, i.mce-i-pasteword, i.mce-i-redo, i.mce-i-remove, i.mce-i-removeformat, i.mce-i-spellchecker, i.mce-i-strikethrough, i.mce-i-underline, i.mce-i-undo, i.mce-i-unlink, i.mce-i-wp-media-library, i.mce-i-wp_adv, i.mce-i-wp_code, i.mce-i-wp_fullscreen, i.mce-i-wp_help, i.mce-i-wp_more, i.mce-i-wp_page {
font: normal 20px/1 dashicons !important;
}
.mce-ico {
font-family: tinymce !important;
}

Dashboard > Forums > Settings > Style (custom css)

Reply
1 Reply
Goodfella
(@goodfella)
Joined: 11 months ago

New Member
Posts: 4

@tutrix This helped, thanks!

Reply