Notifications
Clear all

wpForo 1.x.x [Solved] Like, Report, Edit, Delete links appear but do nothing

5 Posts
1 Users
0 Likes
1,410 Views
hgm
Posts: 5
 hgm
Topic starter
(@hgm)
Active Member
Joined: 5 years ago

Hello,
I have been through the forums here and see that others have had similar issues. My forums are on a site on WP Engine. I have turned minify caching off for my theme and am not using any of the plugins on your known conflicts list ( https://wpforo.com/community/faq/conflicts-with-other-plugins/) although I did have BBPress installed it is now completely uninstalled and wiped.

For all users (including Administrators) the links appear on the front end but do not get beyond the loading animation or go nowhere on submit (report & Delete forms). Obviously unless we can fix this we will not be able to launch the forums.

Plugins that are active include:
Akismet Anti-Spam

Divi Blog Extras - Add new blog layouts in Divi theme
   
Forums - wpForo

Gravity Forms
   
Gravity Forms MailChimp Add-On

MailChimp for WordPress

Share Buttons by AddThis - NOT activated but installed

Select Smart Slider 3

Timeline Express

Timeline Express - HTML Excerpts Add-on

As in this earlier post - In Customizer Theme Preview mode everything works correctly. But when I am on the live site it doesn't anymore ( https://wpforo.com/community/how-to-and-troubleshooting-2/cannot-edit-or-delete-posts-2/#post-9221)

None of these seem like they would have javascript conflicts with WPForo, but just in case I will turn everything off and see. WPEngine has aggressive caching but not minification or anything.

I think the fact that it works in Theme preview mode is a clue, but not sure what it means.

thanks in advance for any insights or fixes

 

 

4 Replies
hgm
Posts: 5
 hgm
Topic starter
(@hgm)
Active Member
Joined: 5 years ago

I have just tested this with ALL plugins turned off except WPForo and Akismet and theme set to 2016 with no customizations. It still only works while in Theme Customizer view. Maybe that view disables some javascript? I purged all caches after disabling plugins and changing theme.

 

 

Reply
hgm
Posts: 5
 hgm
Topic starter
(@hgm)
Active Member
Joined: 5 years ago

Sorry for all the posts but I can edit and I forgot to say that WPForo debugger is turned on now if that helps.

Reply
hgm
Posts: 5
 hgm
Topic starter
(@hgm)
Active Member
Joined: 5 years ago

Hi
WordPress Engine support and I have determined that this behavior is due to their caching protocol. Setting up a staging site without caching the plug in works great.

What I need now are the the specific cookies, PHP arguments or URI strings that they can turn off caching for on the live site. We tried doing it by URL but it didn't work. Please let me know what to pass to them as soon as possible (trying to launch this week and we need to fill the forums up 🙂 )

Thanks in advance and I hope this helps others on WPE using your great plugin

Reply
hgm
Posts: 5
 hgm
Topic starter
(@hgm)
Active Member
Joined: 5 years ago

Update - issue was due to live site not being set to use https - they set it to do either https or http and now the links for users work. FYI for future troubleshooting

Reply