Notifications
Clear all

wpForo 1.x.x Links in Hidden Categories Visible on Recent posts and recent topics widgets

14 Posts
3 Users
2 Likes
726 Views
ice
Posts: 26
 ice
Topic starter
(@ice)
Eminent Member
Joined: 4 years ago

I have some forums which are hidden to certain users but when a post is made in those categories, the link to the post is visible in the sidebar widget to users who are not supposed to see it. E.g a guest users sees in the sidebar a link to a post which is in a category that is supposed to be no access for guests.

And when they click on the link, it goes to a page that shows the actual url in the browser but displays a 404 error as content. Sometimes it just links to the forum homepage at /forum

Why is this happening and how can it be fixed?

13 Replies
Robert
Posts: 9363
Admin
(@robert)
Support Team
Joined: 6 years ago

They will not be visible if you make sure all forum of that categories are set correct permissions one by one not just the top category. then delete all caches in Dashboard > Forums > Dashboard and you're ready.

 

Reply
ice
Posts: 26
 ice
Topic starter
(@ice)
Eminent Member
Joined: 4 years ago

Thanks @robert I have already done all these things yet the issue still persists, I've even accessed the site from other devices just to be sure yet its still happening.

Note that the hidden posts do not show up in the category list main page view but only in the side widgets. And it wasn't always like this, only noticed it recently.

You can get my website url in the video I sent to you on this other thread

On the sidebar, the post "Forum Rules" is rooted in a category that is supposed to be No Access for guests.

cc @sofy

Reply
5 Replies
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9363

Thank you @ice,

This bug is reported, we'll fix it in next version soon:

https://wpforo.com/community/general-forums-bug-reports/links-to-topics-in-hidden-forums-appear-on-the-recent-post-widget-as-viewed-on-chrome/#post-25091

Reply
CENTRAL4ALL
(@central4allgmail-com)
Joined: 4 years ago

Honorable Member
Posts: 464

Isnt it better to add it like option in the widget settings ?

Something like , saw hidden topics topics replies?

Reply
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9363

I think so, this is also possible. but it'll also show unapproved posts, we can't filter them.

Reply
CENTRAL4ALL
(@central4allgmail-com)
Joined: 4 years ago

Honorable Member
Posts: 464

My problem is that i dont have this problem 🤣 🤣 🤣 🤣 🤣 

Reply
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9363

That's well described here by @crisw :

https://wpforo.com/community/general-forums-bug-reports/links-to-topics-in-hidden-forums-appear-on-the-recent-post-widget-as-viewed-on-chrome/#post-25077

Reply
CENTRAL4ALL
Posts: 464
(@central4allgmail-com)
Honorable Member
Joined: 4 years ago

I want to make exactly this,

i have hidden categories , that only top members can get in.

I want to show to the rests the replies in the widget without to let them read the posts.

My problem is that the replies are not visible in the lasts posts widget.

Ho can i do that?

Reply
1 Reply
ice
 ice
(@ice)
Joined: 4 years ago

Eminent Member
Posts: 26

LOL What you are looking for is what I'm trying to get rid of. Unfortunately I don't really know why mine is behaving like this but I am hoping @sofy and @robert may be able to help me fix it.

Reply
CENTRAL4ALL
Posts: 464
(@central4allgmail-com)
Honorable Member
Joined: 4 years ago

Exactly LOL ,

can you send me /post a screenshot of your settings ?

 

Reply
3 Replies
ice
 ice
(@ice)
Joined: 4 years ago

Eminent Member
Posts: 26

I think this is a bug, irrespective of the settings. Seems the developers are aware already. But here are the settings, nothing different or special.

Reply
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9363

I meant the widget settings not the forum. When you set 0 the Limitation of posts per topic the problem arises, or vice versa...

Reply
ice
 ice
(@ice)
Joined: 4 years ago

Eminent Member
Posts: 26

Oh ok. My current setting is 0

Reply
Share: