Notifications
Clear all

My forum emails go to spam folder

6 Posts
4 Users
1 Likes
141 Views
Joselito
Posts: 70
Topic starter
(@joselito)
Estimable Member
Joined: 10 months ago

Anybody else with this problem?Whenever someone registers or gets quoted emails go to spam folder.

Is there a way to fix this?

😥

Topic Tags
5 Replies
dimalifragis
Posts: 1813
(@dimalifragis)
Noble Member
Joined: 3 years ago

Hi,

All email is handled by Wordpress and not wpForo.

Probably your EMAIL smtp server is blacklisted? Or flagged as a high risk one?

Reply
2 Replies
Joselito
(@joselito)
Joined: 10 months ago

Estimable Member
Posts: 70

@dimalifragis

It shouldn't be blacklisted.

Do you think that using gmail account would improve things?

 

 

Reply
dimalifragis
(@dimalifragis)
Joined: 3 years ago

Noble Member
Posts: 1813

@joselito Gmail smtp is not for such usage. Of cource not.

Try to use some smtp plugin for your outgoing email.

Reply
RealAct
Posts: 171
(@realact)
Estimable Member
Joined: 5 years ago

@joselito this is a common problem, most likely your WordPress is not properly configured to work with the PHP mail() function, so mail is not being sent with all the mail protocol authentication requirements, so mail coming from your site is being flagged as spam by e-mail providers. In most cases, it's better to use SMTP if your WordPress and hosting is properly configured to work with it. 

I would suggest you to use the plugin WP Mail SMTP, and perhaps even better with a service such as smptp.com or sendinblue.com the last one lets you send up to 300 emails per day for free!

Cheers!

Reply
VereK
Posts: 393
(@verek)
Honorable Member
Joined: 5 years ago

You will need your domain DKIM,SPF and PTR to be setup rock solid in your domain DNS settings and if possible, a DMARC record too. Even then it can take time to build your email server's reputation.

@RealAct suggestions above are solid. Those third party email senders can be helpful if you cannot easily manage own server system, either by yourself or via your hoster.

Reply