Notifications
Clear all

wpForo 1.x.x [Solved] no forum selected

2 Posts
2 Users
1 Likes
822 Views
Vít Hofman
Posts: 139
Topic starter
(@vit-hofman)
Estimable Member
Joined: 4 years ago

Text: "no forum selected" which appears if I want to add a new topic can not be translate.

It is missing both in wpForo and LOCO translate phrases.

1 Reply
Sofy
Posts: 4057
 Sofy
Admin
(@sofy)
Support Team
Joined: 5 years ago

Hi @vit-hofman,

Thank you for letting us know. This will be fixed in next version release. If you need to resolve this asap  please follow this steps:

1. In the wp-content/plugins/wpforo/wpf-includes/class-template.php file find the following line (line 157)

<option class="wpf-topic-form-no-selected-forum" value="0">-- <?php _e('No forum selected', 'wpforo'); ?> --</option>

2. Replace to this one:

<option class="wpf-topic-form-no-selected-forum" value="0">-- <?php wpforo_phrase('No forum selected'); ?> --</option>

3. Navigate to Dashboard > Forums > Dashboard admin page, click on [Rebuild Phrases] button

4. Navigate to Dashboard > Forums > Phrases admin page, find the "no forum selected" phrase and translate it.

Don't forget to delete all caches before checking.