Notifications
Clear all

wpForo 1.x.x [Solved] No Topics After Migration to another Domain

9 Posts
2 Users
1 Likes
335 Views
jestew
Posts: 7
Topic starter
(@jestew)
Active Member
Joined: 1 year ago

@robert - I'm having the same trouble. I just migrated my WordPress site to a new hosting provider and WpForo wanted me to upgrade - after doing the process of "fixing" the database I now have this:

Forums 4
Topics 0
Posts 156
Members 19

 

So when I go to any forum - it says: "No topics here". I've attempted the process above but nothing seems to regenerate the topics.

 

wpForo 1.9.9.1

WordPress 5.8.2

8 Replies
8 Replies
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2405

Hi @jestew,

Go to Dashboard > Forums > Moderation, press on published button, check are there any topics, if not that means that the topics hadn't been migrated, if there are topics then go to Dashboard > Forums > Dashboard and press Rebuild Threads Button.

jestew
(@jestew)
Joined: 1 year ago

Active Member
Posts: 7

@chris - There are no topics in the DB. Looking at the DB tables using PhpMyAdmin they have no rows. How can I regenerate the topics? I have the old DB dump. Should I just import it into a DB and copy the old topics over to the new table and juggle the IDs? I was hoping there was an easier way.

jestew
(@jestew)
Joined: 1 year ago

Active Member
Posts: 7

@chris - I went back to my DB dump... and there wasn't a topic table? Is this new for 1.9.9.1? How can I get WpForo to create one for me?

Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2405

@jestew,

Your problem is not related to wpForo or the wpForo update, it is related to the bad migration, you need to migrate wpForo completely without errors, migrate all wpForo files.

jestew
(@jestew)
Joined: 1 year ago

Active Member
Posts: 7

@chris - thanks again for the response. I don't understand when you say "bad migration" - what bad migration? I migrated my WP without problems and WpForo upgraded with no errors. It was when I attempted to use the forum I discovered no posts in any of the forums. WpForo never warned me there was a problem.

I no longer have access to my old WP installation, I only have the DB .sql file. Do you have any advice on how to do a migration? Thanks...

jestew
(@jestew)
Joined: 1 year ago

Active Member
Posts: 7

@chris - I realize this wasn't clear. In my OLD DB (pre 1.9.9.1) there was no topic table. But in my new DB (1.9.9.1) there is a topics table but it is empty. Somehow in the upgrade step that wpforo ran, it didn't populate the new topics table. Is that a script that I can re-run?

Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2405

@jestew 

The import of the old WP database backup file was not completed. wpForo detects missing tables and create them again, but it cannot fill them with your data because they have not been imported. So you have only one option. Find the old WordPress database, restore it in some database, then find the wp_wpforo_topics table, export that table and import to the new WordPress database.

jestew
(@jestew)
Joined: 1 year ago

Active Member
Posts: 7

@chris - thank you, I went back to look and I see what you mean - the DB dump I made only has half the wpforo tables for some reason. Sadly, the old DB is gone never to walk the earth again. Thank you for sticking with me until I finally understood. Cheers! jas...